No audio device

  MuDelta 09:52 20 Mar 2007

Elite E6600 Express. I got an X-FI audio card with this machine but I did not want 7.1 speakers because I do not use the machine for music - just for speech and I want to use the two Creative SBS250 speakers which I already have. I can get no sound out of them when plugged into either the X-FI card or the on - board sound socket. When I look in Control Panel/Sound and Audio Devices the volume control etc is all greyed out and there is the message “no audio device”. I urgently need sound because I use want to use voice recognition and VOIP a lot.

After a visit from a Mesh engineer (Mesh said the cause might be a dud card) and a trial of a new card there was no change – still no sound. Further phone consultations sent me a motherboard installation CD (“it might be the MB drivers”) with no good result and then it was identified that I had been sent the wrong X-Fi installation CD with the machine. I have just installed the contents of this CD and still there is no sound (“no audio device” etc). The card is said to be working OK. Any ideas?
I am in deep despair!


  ArrGee 10:14 20 Mar 2007

Have you checked to see if there are any hardware device conflicts?

Control Panel - System - Hardware - Device Manager

Are there any yellow warnings against any of the devices?

  MuDelta 10:36 20 Mar 2007

Ihave checked, there are no conflicts.


  ArrGee 10:39 20 Mar 2007

Go into the device manager and down to the Sound, video and game controllers.

Right click on each device and then 'Update Driver'

See if any new drivers are installed.

  MuDelta 11:16 20 Mar 2007

Drivers are up to date.

  [email protected] 11:19 20 Mar 2007

Go to Start > Programs > Creative > SoundBlaster X-fi > Creative Speaker Connection Wizard. Use this to set up your speakers. You will also find Creative Diagnostics off the same path. Run through these before you mess about with drivers.

  ArrGee 11:37 20 Mar 2007

Having had a look at the specs of your machine, it looks as though it comes with nForce4 AC'97 onboard for your sound.

Do you have the correct AC'97 drivers installed?

Try downloading and installing this:
click here

  MuDelta 12:32 20 Mar 2007

[email protected]

On My machine, Creative does not have a SoundBlaster X-Fi file nor is there a Creative diagnostics!

  MuDelta 12:33 20 Mar 2007


Tried that but no change!

  ArrGee 12:54 20 Mar 2007

Here is somebody who has had similar problems
click here

There are 4 pages of possible solutions, one may be good for you.

Hope it is of help.

  [email protected] 17:00 20 Mar 2007

OK, seems like you have the sound card but no software/utilities installed for it!!!
This can all be obtained on the Creative site.
Are you using two simple "passive" speakers? The 2 Creative cards I have in use require "active" speakers (with an amp to drive them). I have tried using passive speakers in the past but the ouput is insufficient.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?