New sanner , still having problems scanning.

  edenworkshops 13:04 15 Jan 2012


I posted a few weeks ago about the problems that I was having with my 9 year old Canon Lide 120scanner. The general consensus, after a lot of discussion, came down to it being a hardware fault, and I thought well it is 9 years old, so we scrapped it and bought another scanner second hand, it is an Epson Perfection 2450 Photo, we saw it working before we purchased it.

I installed it a couple of days ago and after a few hiccups I managed to get it working....I thought.

I only use it occasionaly for scanning b & w documents.

I tried it this morning from within Photoshop I managed to get to the scanner interface, but when I tried scanning, a message came up saying there was a problem, I forget exactly what it was, sorry. I tried several more times after re-booting but I kept getting this error message....

Could not open the Twain source. Make sure there is a valid source for your scanner in the Twain Directory found in Windows Directory.

.... I checked that, everythings ok.

So, what do you think folks?

Thanks for your help.



  johndrew 13:18 15 Jan 2012

What is your OS?

Did you get a 'new hardware found' message when you first connected it?

Does it appear in 'My Computer' when switched on or in 'Control Panel/Scanners & Cameras'?

How is it connected, wireless or USB? If USB have you checked the lead and changed the USB port connection?

Was there any additional software with it that it may need to function?

  KRONOS the First 13:21 15 Jan 2012

Different scanner but worth a look.Twain.

  edenworkshops 13:47 15 Jan 2012

Hello johndrew

Thank you for your replym in my haste to post I forgot to mention...

OS = XP Pro sp3

Cannot remember if I got the "found new hardware" message, sorry.

Does it appear in my computer? Yes, but when I double click on the icaon I get this message...

...The scanning software could not be found, or your scanner is not connected. Please make sure your scanner and scanning software are correctly installed.

Connected by usb.

I have checked the connections and tried plugging into another socket.

The only software that came with it was the makers installation disk, which I installed when setting up the scanner.


Thank you I will check it out.



  hssutton 13:54 15 Jan 2012

Drivers and manual can be found here Epson Perfection 2450 Photo

  edenworkshops 14:08 15 Jan 2012


I am downloading the latest driver now.

Should I just install it over the exisiting driver?


  hssutton 21:58 15 Jan 2012

Not sure if that's the correct procedure, but that's what I did with the Canon scanner software

  robin_x 22:14 15 Jan 2012

Also try restarting the Print Spooler.

Start/Run services.msc

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?