New router can't see networked hard drive

  Kate B 22:26 11 Jul 2008

hello chaps - just replaced my router (a DLink DSL G624T) and it won't see my LaCie networked drive which is connected to it via ethernet cable. The IP configurator hangs (though it sees an IP address) and I can't connect to it via a browser).

Any ideas? On the old Belkin router it was configured as a mapped network drive.

  dawood 02:15 12 Jul 2008

Try to connect to other port or use other network cable (maybe there is problem on cable).

  Kate B 20:58 12 Jul 2008

I have already tried exchanging the cables and trying other ports - neither of those is the problem. It worked perfectly with my old router.

I'm running the LaCie configurator wizard and it seems the router has assigned it an IP address, but the configurator fails when it tries to ping the IP address. Nor can I access it by typing the IP address into the browser.

I'm tearing my hair out - it was working fine with the old router just 48 hours ago so I don't think the disk itself has failed, not least because it's still spinning fine.

  Kate B 21:20 12 Jul 2008

On further investigation, the drive gives itself an IP address of, whereas if I try and assign that IP address in the router's setup, it only accepts the range - I don't seem to be able to change the disk's IP address ... is it therefore outside the range?

  brundle 21:38 12 Jul 2008

It should work, only 0 and 255 are out of bounds with the usual subnet mask. Have you tried disabling the router's built-in firewall? Does it have options relating to ICMP and PING somewhere in the firewall/security settings?
Does the drive show up if you do an

arp -a

at the command prompt?

  Kate B 21:41 12 Jul 2008

hi brundle, yup, the router's firewall is disabled. I'm on the Mac at the moment so can't check that command but the drive doesn't show up in Windows as on the network, nor in OS X as being on the network. And no, the config pages don't seem to offer those options.

  brundle 21:56 12 Jul 2008

The drive is assigning itself an address in the wrong subnet, you need to change your router's IP range to - 254 if you can't set the drive's address to The router will only give out addresses in its DHCP range so it appears the drive is set to use that address regardless.

  Kate B 22:21 12 Jul 2008

that's what I thought - however, I can't change the IP range. Looks like I'm stumped!

  brundle 23:02 12 Jul 2008

Seems something's not right - I've never seen a router that uses that range by default, and it seems rather odd that they'd choose a fixed address that would prevent owners just plugging in and letting it configure itself. Which model is it? I picked a model at random on the Lacie site (Ethernet Big Disk) and the manual says it uses DHCP if available.

  Kate B 23:46 12 Jul 2008

It's the Lacie Ethernet Mini - called the Edmini. The configuration client is very minimal and doesn't seem to accept changes. An exceptionally geeky friend thinks it might have cached some settings but there's no way that I can see to flush the cache.

It does have a box to tick for DHCP, though, but it doesn't seem to do anything.

  Ashrich 10:54 13 Jul 2008

The 2.1 subnet is for the Belkin , maybe it is still using the old settings ...there must be a way to change them , there is something about it here , click here .


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?