New Printer wont work on Network

  Alf58 23:44 02 Jul 2006

I have a home network consisting of four machines all running Win Xp. Two are laptops and two are desktops. The network runs on a a Belkin 54g ADSL Modem/Router. Everything was working fine until the printer packed in(a Lexmark).That printer had worked well for three years and it was possible to print on it from all machines on the network.

I purchased an Epson Stylus C48 and plugged it in to the main desktop(the one hard wired into the router) It worked fine on that machine. Trouble came when I tried to print from any of the other machines. I carefully unistalled the old printer drivers. Followed the Wizard to install the Epson as the default printer on the other three machines but I cannot print from any machine except the one physically connected. The Printer icon is there and it says the the documents are printing but nothing actually happens. I have disabled the firewalls to no avail. I have used the windows printer troubleshooter to no avail.

Can anyone help? I am well and truly stumped

  AndySD 01:45 03 Jul 2006

I know this sounds basic but have you right clicked on the printer and shared it? If you have try removing the share then reboot and right click on it and reshare it.

  mgmcc 10:06 03 Jul 2006

Here's my standard "blurb" for setting up a network printer:

1) Connect the printer to the "client" PC, as though it were to be used with that computer, and install it. This ensures that it has all the necessary software/drivers on board.

2) Reconnect it to the "host" PC and, in its Properties, set it as "shared". In the client's "My Network Places" (or Network Neighborhood), the printer should then appear as a shared resource of the "host" PC along with any shared folders. Double clicking the printer in the remote PC should automatically install it as a "network printer" in the "client". This means that the "client" now has the same printer installed twice - once as a "local" printer and again as a "network" printer (with a bar under the icon to indicate a network device). If you are always going to print via the network, you may want to set the "network printer" as the default.

Otherwise, have a look at this Microsoft article. It is an old article written for Windows 95, but the basic principle for installing the network printer should still be valid.

click here

  Alf58 20:05 03 Jul 2006


I tried your double install idea to no avail. I am well and truly stumped. I'll try the Microsoft thing but I'm not sure if I've got all day!

Could it be to do with Norton AV? I have that installed on the host machine and though I disabled it, I couldnt disable the anti spyware function. The old lexmark was already on the system before I got the Norton AV so I presume it got detected and allowed. Any thoughts?

  spikeychris 20:15 03 Jul 2006

Is eventvwr displaying anthing?

Run and type eventvwr. The System or App records should flag up the problem.

  ade.h 20:40 03 Jul 2006

Nothin whatsoever to do with an AV. Firewall perhaps/possibly, but not an AV.

"I have disabled the firewalls to no avail". Many firewalls cannot be completely disabled, just for the record.

  Alf58 20:53 03 Jul 2006

My Belkin Router has a built in Firewall! Is there a way I can tell if the Belkin router firewall is stopping the client computers communicating with the printer on the host? The old Printer was already connected and in use when I got the Belkin so I suppose it was detected etc when the Belkin was setting itself up. What settings do I need to look at in the Belkin interface to see what is going on?

  spikeychris 21:11 03 Jul 2006


  ade.h 21:53 03 Jul 2006

NAT/SPI/Port firewalls do not block printer sharing, given that it is integral to networking. Unlike internet access, which not everyone wants on a network.

  Alf58 00:02 04 Jul 2006


the activity logs dont seem to suggest any error they just report the installation of drivers etc. There are no messages associated with with printing problems. The error message I get from th Epson software (after a while) is "communication error" together with a request to check all connections and restore power supply if has been interrupted.

I've emailed Epson's tech support but no doubt they'll tell me how to configure printer sharing on an Xp network which I know already.

I'm slightly depressed: I got a shiny new printer that only works on one machine!

  Robinj 19:18 28 Aug 2006

I have same printer, same problem. I understand the problem relates to the Status monitor Agent software introduced by Epson. Epson suggest allowing it through the firewall is risky.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?