New HD letter designation G:\

  ThePharcyde007 07:54 07 Sep 2004

Hi I have just installed a 20GB HD to replace my partitioned 120GB what had a 20GB partition for windows, and the rest for data. I have now installed windows XP Pro on my new 20GB HD and using partition magic, have now deleted the old 20GB partition and now have just 1 120GB HD D:\.

My question is I had to install windows on my new 20GB HD, but because my old drive had C:\ for the 20GB partition, and the remaining D:\ my new HD has been designateD as G:
Is there anyway to now rename this to C:\ because my larger 120GB is now only called D:\ after I resized the old partionion and merged it with D:\.

Make sence!!!


  Diodorus Siculus 07:58 07 Sep 2004

Right click on my computer

choose manage

then disk management

right click on the drive

change drive letter and path

That should do it - you may need to change them carefully though. Sometimes programs are installed to a certain place and react badly to their paths being changed.

  ThePharcyde007 08:01 07 Sep 2004

Hi Diodorus Siculus, does not let me saying it is the boot drive


  johnsims 08:06 07 Sep 2004

Your new drive should be set to master (jumpers), and the partition to primary and active (in Partition Management).

Start | Administrative Tools | Computer Management - Storage - Disk Management. Click on Actions on the top menu, all tasks and choose Change Drive Letters and Paths. (alternatively right click on G: and from the menu choose Change Drive Letters and Paths.

  cga 08:09 07 Sep 2004

Unfortunately renaming through Disk Management does not work for the system partition.

There is a procedure but I would not recommend it as it involves registry modification.

However you "just might" be able to correct this by partially reversing the cause (I am being cautios because I am not clear on the procedure you used).

As you created this situation by using Partition Magic I am guessin that you are now not booting from the first active partition on the first disk.

You might find that, if you change this, the situation will correct itself.

Note: In general terms, if you externally alter the relative position of the boot partition XP will work out its drive letters afresh. (This can be annoying when you dont want it to happen!!)

  cga 08:29 07 Sep 2004

Just to clarify a couple of things about XP booting :-

1) Under normal circumtances you will always boot into the first partition on the first disk regardless which partition holds your XP system. BOOT.INI in that partition then points to the partition holding your XP system.

2) In the normal (simple case) the XP system is in the same partition.

3) While this is the way that XP likes to setn the system up - it does not have to be this way. You can set D1P2 as the active partition and it can hold a Boot.ini that points to D1P2 as the system partition.

This can be very useful in certain recovery scenarios but is not for the faint hearted.

Next, XP works remembers it's partition letters by a combination of Disk Identity and relative partition number. However, in this case (unlike boot.ini), hidden partitions are discounted.

Partition Magic is a great tool, I would not be without it, but it does let you get yourself into trouble if you dont know how XP works out the partitions.

My assumptions is that, when you did your changes, XP started up thinking it could see another partition that was the one it knew as C:, (remember it uses disk identity and not relative disk number), so it renamed the new partition G:.

It should operat fine like it is but, As you have Partition Magic, you can use it's utility to change any references to C: into G: to correct any problems.

  ThePharcyde007 12:49 07 Sep 2004

cheers il try when i get home tonight :-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017