New Hardrive ?

  BooST 20:12 06 Jun 2003

Dear All ,

Forgive me for being naive but I thought it was easy to install a new hard drive on my pc with windows Xp OS .Let me fill you in, last week I went out and bought a brand new 120 gig hard drive as my original 40 gig was getting a bit on the full side.
I have a sony DVD drive (D) and a Cd ReWriter (E).
I have been told by various people that Xp doesn't like loading from a Cd-R drive so that was disconnected to be on the safe side.
Hard drive was set to single/master drive and added on the same ribbon as the DVD drive.
Turned Pc on and went into Bios settings and made sure my drive was the listed as Primary master drive and settings correct,then into power management and made the boot setup to do cd rom first.Save and exit and restart Pc,cant find dvd drive nor will it load from Cd-R cause it causes an illegal page fault.After various attempts I decided to take me daughters old std 40x CD Rom out and fit that to my Pc and as before went through the motions and to my surprise it found it and up come the blue screen and started to load, but after two minutes said please insert the disk into CD Rom and press ok which I did but it kept showing me the Message.
I then turned it to look for my A: drive which it found no problem and using a windows 98 back up disk managed to Fdisk and format the drive but even after that I can get Xp on it.
I have put it in the system as a slave drive and as such can use it to put info on it but its just a storage device then with no pupose.
If anyone can tell me what ive done wrong I would be most happy as I dont have much hair left and what is left I would like to Keep rather than pull it out through stress


  Lú-tzé 20:24 06 Jun 2003

Put the new HDD on the Primary IDE channel as master.

Have an optical drive (cd-r / DVD) on the secondary IDE as master.

Put the XP cd into the optical drive and all should be well. Tell the BIOS to boot from dvd first, then floppy then hdd. After that, just reboot and off you go.

  Philip2 20:57 06 Jun 2003

First you should not have your hard drive connected at any time to the same cable as your DVD drive or your CD-R as it can cause data transfer problems you shoud have three connections on your mobo one for your Hard drive the other for your DVD rom drive the other for the floppy drive.
If you have a floppy ME start up disk boot with this choose install without cd support it will take you to dos and A:/ will appear type in fdisk and delete the none dos partition or if there is nothing to delete go to delete the prime dos partition i do not no what OS is on the HD all data on your hard drive has been deleted.
Go into bios and change to first boot cd rom put your XP into disk drive reboot choose advance and choose a new install XP will format and reinstall.
Is your 120gb HD working with your MOBO as it seems a big jump from 40gb to 120gb they are not plug and play do's it match your MOBO spec??
Your DVD drive should be set to master and your CD-R should be set to slave.

  BooST 21:11 06 Jun 2003

Lu-tze tried your suggestion and this it what happens.
Top Cable(brown slot) goes to DVD Drive and comes up with secondry master.
Middle cable (blue slot) goes to HDD and comes up as primary master.
Bottom Cable(black slot) goes to floppy

boot sequence is 1st cd 2nd floppy then HDD last.

reboot and I get searching for boot record on cd rom not found,searching for boot record on floppy not found,searching for boot record on ide-0 ..ok
NTLDR is missing
please reboot


  BooST 21:58 06 Jun 2003

tried your idea and deleted the partion.
The only boot up disk i have is from 98 but seems to work ok.
reboot and you get the same thing as before ,fails to boot or if in dos you get CDR101:not ready reading drive

Any more idea's


  BooST 22:10 06 Jun 2003

Just for reference ,my motherboard is an ECS KT7S5A so I dont know if this compatable with a 120 gig hard drive ?


  Brian-336451 22:13 06 Jun 2003

Just after you switch on and the computer checks the RAM it is possible to see your EIDE devices.

Is your CD showing up here, if it isn't it is possible that you've misaligned the data cable when attaching it to either the mb or device. (The cables are supposed to be idiot proof, but this idiot can get round most of these 'safe-guards).

You said in the first post that your harddrive was set to single master, is there another device on that cable, if there is the hd should only be set to master and the other to slave.

I have my two hard drives on the same cable and a CDrom and CD writer on the same cable, this is not ideal BUT it WILL work. The reason I have it that way is that the EIDE cables will not reach any other way. I'm told that it will inhibit on-the-fly cd copying but I always save to disk first anyway - its more reliable and works out to be faster.

  clayton 22:17 06 Jun 2003

on your motherboard you should have sockets marked IDE1 & IDE2 connect your hard drive to IDE1 if the cable for the hard drive has a coloured end that should fit to the motherboard,make sure the jumpers on the hard drive are set to master, connect your DVD drive to IDE2 & set jumoers as master for now you can change it later if you need, in your bios set the pc to boot from your dvd drive first, when you restart your pc it will ask you to press any key to boot from cd.

  Philip2 00:01 07 Jun 2003

I am sorry you have not had any joy so far CDR101 is a rom drive error so the error must be the way it is connected IE cable connection to the drive or the motherboard or a fault on your drive or it needs a driver.
Is your HD showing in the bios? also check that your jumper on your DVD drive as i cannot see why it is not being detected do you get the same result using the CD-R drive??.

  BooST 22:25 08 Jun 2003

Been trying to get this thing to work and in the process gatherd some more info for anyone one that would like to help in this matter.
Bios detecting hard drive and cd rom.
Hard drive set to master on ide-0 on ide cable 1.
Cd rom on ide cable 2 as secondry master.
Boot sequence = cd rom/floppy/ide-o.

Then I get searching for boot record from cd rom...not found.
searching for boot record from floppy..not found
searching for boot record from ide-0...ok

Boot failure from previous device
Boot failure insert boot diskette into drive A

Using 98 boot disk I Fdisked the HDD and set partition.
Now its searching for boot record from ide-0..ok
Missing operating system

you then have to reboot.
reboot with disk brings you back to A: prompt.
A:\setup.exe=CDR101:not ready reading drive E
FORMAT C: = formatted ok and gave me serial number.
Drive E:=Driver MSCD001 unit 0
Even if you E:dir you still get CDR101 not reading drive E.
Put it all back together with old hard drive and it starts up with no problems apart from loosing the date and time.
Only have the DVD on the ide2 cable.
Though I would check out the drive again.
Windows Xp wont run doesnt recognize its in there
Windows 98 disc runs ok
Music disc does run ok
Pc advisor DVD runs ok
Red dwarf DVD doesnt although does on another DVD
Disc cleaner doesnt
Cd-r doesnt but use to
Tried another Pc advisor DVD and it didnt work
Tried another music cd and it doesnt work
Properties insist it is working ok
no question marks in device manager other than a couple for some scsi mini port that i never knew i had.
Add hardware says its working
Uninstall and reinstall ok
Win dvd installs ok
Cd-r still doesnt work
Grand theft auto wont play but it did the other day.
Pc advisor now plays again
Red dwarf now plays ok
dukes of hazzard still wont play
98 still works
So to some it up weve got some audio cd that will play and some wont,some dvd's will and some wont and some media cd's will while some wont but all the ones that dont used to a couple of days ago before i tried to fit this HDD and windows Xp still dont work.

Any help and this would be appriciated


  Brian-336451 22:46 09 Jun 2003

If the Win98 disc works, re-install Win98 then once its running it may be possible to 'upgrade' to XP.

As I see it you've not a lot to lose as it stands.

Just a thought, you keep talking about drive E. If you use the Win98 boot disk, it often moves your CD rom by a letter.

Have you tried accessing for example drive F: or even G: possibly, that's happened to me before now?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires