New hard drive slows pc down

  Biker Dave 15:55 27 Mar 2006
Locked

Have previously posted ref formatting times and now managed to format my new drive however it has dramatically slowed everything down. The pc is running XP home with SP2. Original boot drive is 40gb Maxtor ide 6L040J2 configured as master with cable select. The new drive is a Maxtor 300gb Diamondmax ide 6L300R0 configured with cable select. The new drive will not format via windows so I used Maxblast 4.0 downloaded as the drive was supplied as oem part. Maxblast told me it needed to reset the bios to accept >137gb. It shut the pc down to do this but hung so I soft booted and then the Maxblast program wizard came up. I used it and it said everything was installed OK and this appears to be true when looking at XP disc management. The problem comes in that with the new drive fitted it has slowed everything down to almost freeze point during data transfer. I tried disconnecting the drive and everything runs fine again. When the drive is connected a 80mb file takes 9 mins to transfer but when not connected it goes in 2 secs! Am i missing something simple? 5 days and still racking my head!

  Totally-braindead 15:59 27 Mar 2006

I'd don't know if this is whats wrong but in the first instance I would take them off cable select and set them as master and slave and see if that does anything.

  Totally-braindead 15:59 27 Mar 2006

You may have to autodetect them in BIOS after you do this.

  Biker Dave 16:00 27 Mar 2006

Sorry forgot to say I have tried that as well!

  Biker Dave 16:01 27 Mar 2006

When booting up the drive is detected, is this enough?

  jimv7 16:15 27 Mar 2006

Are you using a 40 or 80 pin ide cable.

Have you tried using a different cable.

  Biker Dave 16:33 27 Mar 2006

Sorry for delay just checking bios again. The pc is 4 years old so I was advised to buy another cable just in case. the one i bought was an ebuyer ide udma ultra 133/100 cable. I havent tried using my original cable, would this handle the data ok?

  ed-0 16:51 27 Mar 2006

Yes.

Have a look in control panel > system > hardware > device manager > IDE ATA / ATAPI controllers > primary IDE channel > advanced settings. What are the CURRENT transfer modes for both hard drives?

  Biker Dave 17:13 27 Mar 2006

Transfer mode = DMA if available
Current transfer mode = PIO mode

This is for both device 0 and 1

  Fruit Bat /\0/\ 17:27 27 Mar 2006

PIO is very slow change to DMA

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

3. Driver is not intended for this platform
If you keep getting the following error message:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

then the way out is to rename C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to something like atapi.old.

If that's not possible, you can try it from the repair console (boot from the Windows install CD and select the repair console).

If Windows always automatically recreates atapi.sys, you can try renaming it in safe mode or from a command line window or you can try to rename or remove it in the driver cache as well.

Desensitize Your Computer's IDE Channels
There's a bit more to it. The following article offers a way to reduce the incidence of this problem, although it still doesn't solve it altogether.

IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
click here

Do read this article because it contains a useful long-term workaround. But you have to go through the procedure described here to re-enable DMA first. Assuming you've done that, insert the ResetErrorCountersOnSuccess registry values mentioned in this article into both the primary and the secondary IDE port registry keys as described.

Unfortunately this is only a half solution, because when you enter an unreadable DVD, you will get 6 errors in a row, and the IDE channel will revert to PIO mode, but at least when you pull out the DVD in time and then insert a good one, the error counter will be reset and it will at least be a bit more difficult for Windows to hobble your IDE drive.

  ed-0 18:39 27 Mar 2006

As per Fruit Bat /\0/\ ^^^^^^^^^^^^^^^^^^^^^^^^^
:-)

You could then test the transfer speed of both drives at pcpitstop. click here Join if you want, it's free or test anonymously. Make a note of the cached and uncached speed of both drives.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

30 UK artists have created vibrant posters celebrating Pride London

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?