New gaming pc build issues

  Elivill 07:50 18 Aug 2017

Hello. I am building my first gaming pc and as I'm building it i can't get it to go to post. First of all when I flip the switch on the psu it turns on for about 5 sec without pressing the power button and then shuts off. Also, I tried this with the power and reset button unplugged from the mobo and it still happens. As far as I know everything was done correctly and is plugged in. I've even switched out the psu and got the same result. Any help on this would be great! 

Specs: 

Intel - Pentium G4600 3.6GHz Dual-Core Processor

Gigabyte - GA-B250M-DS3H Micro ATX LGA1151 Motherboard

Corsair - Vengeance LPX 8GB (1 x 8GB) DDR4-2400 Memory

SanDisk - X400 256GB 2.5" Solid State Drive

Gigabyte - GeForce GTX 1050 Ti 4GB G1 Gaming Video Card

EVGA - BQ 600W 80+ Bronze Certified Semi-Modular ATX Power Supply

Asus - DRW-24F1ST DVD/CD Writer

NZXT - Phantom 410 (Red) ATX Mid Tower Case

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Les meilleures enceintes Bluetooth à moins de 150 euros