New DVD drive not working

  willy boy 19:34 22 Jan 2007
Locked

I have purchased a Sony DVD drive AW-G170A to replace a dead Samsung dvd /cd combo drive in my Dell 2300 Dimension. The drive is recognised by my system as D: but will not read/play audio cd, cd-rom, or play dvd's. I also have a lite-on dvd drive (borrowed) that will perform all functions that the sony will not. If I rip music I have to do it from the Lite-on but this drive will not write to CD-R. The Sony drive will burn to the CD-R but then will not play the CD it has burned in media player! If I put the CD in the lite-on drive it plays properly as do DVD's. I am wondering if the drive is a dud and should I return it. I have tried fixes I found on the forum such as uninstalling and re-installing, removing filters from the registry as recommended, neither microsoft or Dell support seem to be able to offer anything.I am using media player 11 and and PowerDVD programs which as I say function perfectly in the Lite-on drive.
Any help would be appreciated before I return the drive to Dabs. I have both drives set to cable select.

  howard64 19:41 22 Jan 2007

try setting the drive as master and connect at the end of the ribbon cable.

  SB23 19:43 22 Jan 2007

Thats the one I replaced mine with. My problems were with the DMA settings. Just a thought.

  Fruit Bat /\0/\ 19:46 22 Jan 2007

The Sony drive will burn to the CD-R but then will not play the CD it has burned

either read laser duff or electronics that align the laser are duff.

Send it back!

  skidzy 19:47 22 Jan 2007

Maybe as Sb23 try resetting the DMA settings click here

  willy boy 20:11 22 Jan 2007

Thanks guys, I have tried setting as master at end of cable, no change,I have checked DMA settings seemed ok but ran the down load anyway, after setting a restore point, still no change. As I have tried most things I think I shall now folow Fruit Bat advice and return.

  Totally-braindead 20:33 22 Jan 2007

If you have access to another PC you could try it on that but I agree it appears that the drive is more than likely faulty.

  willy boy 13:10 23 Jan 2007

Once again thanks to all, drive is on its way back to DABS

  Stuartli 13:30 23 Jan 2007

I have the same Sony rewriter - it's not missed a beat so far.

As per the advice given before, drop Cable Select (which normally requires a motherboard that supports it in any case) and set/rejumper the rewriter as the Master and any other drive as the Slave.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?