New DVD drive installed

  snowy30 20:32 02 Jun 2007
Locked

Hi

Yesterday, I installed a new LG GSA-H55N DVD Rewriter; I connected it to the cable marked 'MASTER' (my other drive an HP Writer has a joint connection marked 'SLAVE').

Before installing the LG Drive I set the jumper on the back of it to CS (Cable Select)I went according to the original Samsung drive I took out.

The new drive works, except it only works in the "PIO Only" setting of the "Secondary IDE Channel" and not when it is set at "DMA if available"; I uninstalled the drive, deleted MasterIDDataCheckSum and SlaveIDDataCheckSum in the Registry and uninstalled the Secondary IDE Channel but it appears I have no luck with either solution.

Could it be solved by taking out the drive and change the jumper setting to MASTER?

  SANTOS7 20:33 02 Jun 2007

Could it be solved by taking out the drive and change the jumper setting to MASTER?

Why not try that first then post back if it does not...

  Fruit Bat /\0/\ 20:49 02 Jun 2007

Drive on end of cable should be set to master, drive in middle of cable should be set to slave.

  snowy30 21:48 02 Jun 2007

Again the new drive reads when in PIO Only mode, and I reset it to MASTER and the current HP Writer to SLAVE.

  Stuartli 22:16 02 Jun 2007

Actually my Master drive, a DVD rewriter, uses the centre connection on the IDE cable and the DVD-ROM drive (Slave) the end connector - doesn't make any difference in my case.

Uninstall both drives in Device Manager. Then leave one of them disconnected and Reboot.

Windows should Find New Hardware and reinstall the basic CDROM driver, which is all that is required.

Now connect the second optical drive and again Reboot.

Windows should again Find New Hardware and install this drive's CDROM driver. The rewriter (Master) should be listed as D and the other drive as E.

Check from Device Manager>each drive's Properties>that "Use this Device" is Enabled.

Regarding DMA. If you can't reset it from Device Manager>IDE Controllers>Secondary IDE Channel>Advanced settings, then run this small file:

click here

  Stuartli 22:18 02 Jun 2007

Also, from the drives' Properties, Enable the drives to use Digital mode to avoid the need for audio cables.

  snowy30 00:31 03 Jun 2007

Doesn't make any difference, I uninstalled both drives and rebooted and the computer will only recognise both drives when they are both connected; hence it installs them both when the second one gets connected.

On trying to play a disc using the LG Drive when it's set to 'DMA if available' I had an error message saying something like the ReadProcessMemory and WriteProcessMemory is not completed.

  snowy30 18:23 03 Jun 2007

The error message I got was: Only part of the ReadProcessMemory and WriteProcessMemory is not completed.

  snowy30 01:29 09 Jun 2007

I've been searching the net for the above problem and one solution I came across is that I might need a new 40-pin cable?

  snowy30 01:51 09 Jun 2007

Or is it an 80-way cable I may need?

  brundle 02:07 09 Jun 2007

Both have 40 pins; 40 way is all you need, optical drives don't use UDMA66/100 for which you need the 80 way cable (extra grounding wires to suppress RF interference)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires