Networking on two XP PC's - Can't 'see' both ways

  kinger 20:29 17 Sep 2003
Locked

Using wireless networking with BT voyager 2000 I have networked my desktop PC to my laptop PC. All is fine and I can use files from my desktop PC from my laptop.

But I cannot see laptop files from my Desktop PC. A friend says it's because the desktop is the Host while the laptop is the client, but surely I should be able to see files from either direction?.

Can anyone advise, please?

  kentylad 21:53 17 Sep 2003

I can see both ways on my laptop/desktop with the desktop as a client. However, that was only until I configured my firewall.

Have you got a firewall or enabled the built in windows one?

Nick

  keith-236785 22:01 17 Sep 2003

are you using zone alarm firewall?

if so on the main screen (zone alarm) click the firewall tab on the left then main tab at the top.

click advanced (bottom right)

then choose "this computer is an ICS/NAT gateway"

your ip address should be shown in the box under this selection, make sure it is your primary ip. that should then open up the network through your firewall.

cant help with any other firewalls as i have only used zone alarm.

good luck.

  kinger 22:31 17 Sep 2003

Indeed I'm using Zone Alarm Pro.

Should the IP address be the same on each PC when entering it into Zone Alarm?

I have ping tested each one and get a return of 192.168.1.3 for notebook and 192.168.1.2 for Desktop PC

However in Zone Alarm it gives 192.168.1.1 on both computers.

I'm offered options of "this computer is an ICS/NAT gateway" and "this computer is a client of an ICS/NAT gateway using Zone Alarm Pro". So not sure which one to tick.

  kinger 22:56 17 Sep 2003

Just to prove a point to myself, I stopped Zone Alarm Pro on both PC's and disabled the firewall on my BT Voyager 2000 Router but still could only see one way ...

I have the Voyager 2000 wired to my Desktop via J145 network cable and am using the BT wireless PC card on my Notebook PC to send receive to the Voyager 2000.

BT also supplied a USB wireless unit for my desktop but I don't seem to need this, it makes no difference whether it's plugged in or not. Overkill on their part I think.

Hope someone can still help.

  Kitz E Kat 23:05 17 Sep 2003

Do you kave a shared folder on the laptop?
IE., have you enabled file sharing on the laptop...

kitz E

  kinger 23:46 17 Sep 2003

Yes, I have enabled file sharing.

When I look in 'Map network drive' both notebook and Desktop appear on the laptop screen.

When I do the same thing on my desktop the network name appears with a plus sign next to it, but on clicking on it, the plus sign just disappears leaving just the name of the network.

  Kitz E Kat 08:48 19 Sep 2003

There is a better fix for this i know, but i don't have the time to check it, im on my Linux Computer at the min.

If you don't crack it in the meantime ill get back with a more elegant solution!!! Sure somebody else will help in the meantime....

Till then, put the files you want to see in the folder on the laptop where the desktop files are viewed, say you have a folder on the desktop, called desktop files, and this folder can be viewed on the laptop, then put the laptop files in the folder desktop files, and you should be able to view them on the desktop....

Elegant no, but it does work, i did it and no probs....

Did you use the XP, network assistant and the floppy it creates ???

Keep posting, you will sort it handy in the end

Kitz E Kat

  kinger 15:44 19 Sep 2003

Unfortunately when I try to move files from my notebook PC into the Desktop folder that I CAN see it won't allow it...says I don't have permission..possibly.

I then made sure that I selected 'allow other users to alter files and folders' on the Desktop PC but I still couldn't copy files from my notebook to the Desktop folder.

On seeing the desktop folder displayed on my laptop, I can copy FROM it, no problem, but not TO it.

I can see anything on the Desktop PC from my Laptop but nothing on the Laptop from my Desktop.

Thanks for your help. This seems to have foxed a number of people but, as you say, there must be a way around it.

  Kitz E Kat 18:14 19 Sep 2003

If you tried the network assistant there is a good chance that it has enabled DHCP...

As your friend says you have a client and a host.....


Try this, you can undo these changes by runing the network assistant again....

Start>Control Panel>Network Connections(i assume you have classic view!)>Local Area Network> you will see a window with a line Internet Protocol(TCP/IP), click on this,Check the Use the following IP address, give it an address, like .... 169.254.225.1,, then click on the Subnet Mask it should enter a number like 225.225.0.0, you should not have to type a number in this box, Click on OK do the same on the other machine , except give it an address 169.254.225.2, the subnet mask should be the same as above, both computers should have the same network name, IE, WORKGROUP,

This will create a peer to peer type network, and you should be able to share OK....




Let me know how you get on,
hope this helps

  kinger 19:28 19 Sep 2003

Ok, tried that but I just lost my Internet connection after altering the settings so I'm reverting back to the wizard.

I got my Internet connection back once I set it to "automatically detect settings"

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

What is ransomware and how do I protect my PC from Petya?

Illustrator Mariana Rodrigues' beautiful flora and fauna for Bombay Sapphire gin

How to remove Mac ransomware

Comment mettre à jour Kodi ?