Network up and running!.... but no ICS... :-(

  Tj_El 21:45 25 Apr 2003

Hiya people,

I have just about been able to set-up the networking between my XP Home and 98SE pc's. They can ping each other which is good..... but I can't connect to the net from the 98 system. The XP is the primary system i.e. that which connects to the net. I can't share the BB connection.

What am I doing wrong here?

In the 98 system, under Network, I have set the "Gateway" as the XP system's IP address and have set the DNS configuration of the "TCP/IP" of the NIC to the IP address of the DNS server.

I tried to ping but get "Unknown host"

Help please....



  PSF 21:53 25 Apr 2003

Have you tried to run the XP networking wizard. Run it on the XP pc and then it will ask if you want to make a disc to set up the other pc's on the network, choose yes and the run the disc on the 98 pc.

When you run the wizard it goes through all the networking and internet options and sets up the pc for you.

  The Pretender 21:56 25 Apr 2003

If you have firewalls running, switch them off and try again

  The PC Doctor 22:03 25 Apr 2003

Can I suggest that you re-set all your TCP/IP addresses back to Auto detect...

Have you got ICS up and running on the XP PC?

Go to tools in your browser and select options, then go to the connections tab and look at the bottom of the form. You should be seeing the setup for your ICS. set how you connect to the net and how you connect to the LAN and press ok.

Now using the XP PC navigate to a site (Any site) and leave it as is with the site on display.

Now go to the 98 PC and again go to Tools > Options and check out your settings. On this PC you should select auto detect and connect via your LAN card.

Now run up Internet explorer and navigate to any site. 1st time may take a few seconds while the PC sorts out the setting after that no problems.

Using this type of setup your XP PC will have to be on for the 98 PC to access the Internet.

I actually put together a web page to cover this... click here and look at my 'Setting up an ICS' page. I put this together whilst on a dial-up but the it also applies to a BB connection.

  Steve27 23:17 25 Apr 2003

If you have the money a really good solution is a broadband router (wireless even better).

  Tj_El 23:36 25 Apr 2003

I have done all that you stated above including installing a little proxy proggie AnalogX which according to testimonials on this site works a treat.

When I tried to access the site, I got a GPF: NETSCP caused a divide error in module DIBENG.DLL

On rebooting same thing happened and when I chose IGNORE rather than CLOSE, I was taken to the site page although it did not load correctly. This error showed up each time I clicked to browse so I think it might have to do with the browser itself (Netscape). I will try installing it again (tomorrow) and hope for the best.

Thanks for your feedback - it was positive and helped me know I was on the right track.

Will post back with results.



  Tj_El 20:42 26 Apr 2003 I have uninstalled Netscape. I will try Opera instead.

This however brings me to another problem: anytime I browse (on the 98 system) the shared directory located on the XP system, the 98 system freezes and eventually I get a BSOD with the message:

Disk Write Error - Unable to write to disk in drive C. Data or files may be lost. Press any key to continue.

As I type this I am wondering... "is it because I have AVG installed on the 98 system?"

Any help deciphering the cause and getting a fix in place greatly appreciated.



  igram 01:06 27 Apr 2003

Try this link click here It Worked for me. Running Zone Alarm and AVG on PC and networked laptop

  howard60 07:24 27 Apr 2003

have you got both hard disks shared? also have you put a file in the shared docs folder? dont know why but a file in the shared docs seems to solve a lot of probs. If all else fails remove both network cards - from control panel then shut down and physically remove them - reboot without them in. Check no cards shown in device manager include view hidden objects on the xp machine. Shut down and reinstall cards - if poss in a different slot - run the xp wizard and set up ics and make floppy for 98 pc - run that. Go to properties of both cards and look in advanced [top right tab] and make sure xp firewall is not running. Again check on sharing and with luck you will be there.

  mnich 11:11 27 Apr 2003

What fixed it for me was to set the following in the TCP/IP properties for the network adapter in the client PC:
Disable DNS
set gateway to the IP address of the host PC
Use DHCP for WINS resolution
Obtain an IP address automatically (this was the setting that fixed it for me - I had previously had it set to a specific IP address)

  mnich 11:14 27 Apr 2003

Also if Zonealarm Personal version is running on host PC, then set the Internet Zone security level to Medium - if it is set to High then the client cannot get through - or upgrade Zonealarm to the Pro version.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?