Network Problems

  ERKA 14:22 05 Nov 2007

Hi everyone new to this forum, i have a home network with two desktops and a laptop connected wireless,but have a problem with one desktop, running vista 32 ,when i log on the pc runs slow and does not respond ,when i check the task manager the networking utilization in the networking section is up and down between 30 and 99% if i un plug the network adapter and plug it in again everything is fine and all works at speed checked and the drivers are up to date for the adapter this happens every time i boot up has anyone got any suggestions would be most appraciated

  The 12th Man 14:51 05 Nov 2007
  ambra4 00:15 06 Nov 2007

How to fix Vista's network bottlenecks

The problem with Vista's new-fangled network stack

All this automatic tuning of the Vista network stack sounds great in theory

But the problem is that some clients don’t support TCP window scaling

Or don’t have it enabled.

Additionally, some firewall products also don’t support it.

If using McAffee uninstall and turn off IPV6

In either scenario, the result is dropped packets, which affects network performance horrendously

Your traffic is literally dropping into a black hole, never to be seen again.

Try this open up an Administrative Command Window

Right-click-Run as Administrator and type in the following command:

netsh interface tcp set global autotuninglevel=disabled

You may also need to type in:

netsh interface tcp set global rss=disabled

The changes take effect straight away, with no reboot needed.

You can also check this site

click here

  ERKA 11:36 06 Nov 2007

Hi guys thanks for the info,when i try to disable the auto tuning level and the global rss i get a message saying that it had failed at ipv4 and the operation requires elevation !! which doesnt mean much to me!sorry for the lack of knowledge but does it mean anything to you guys? cheers

  ambra4 12:03 06 Nov 2007

Did you uninstall IPv6???

Windows Vista contains both the familiar IPv4 stack and the new IPv6 stack.

IPv6, when it's rolled out across the Internet over the next few years, will bring an end to the problem of running out of IP addresses and improve other aspects of TCP/IP operation.

However you do not need IPv6 at present time.
You need to uninstall it, click Start, click Run, type CMD, and hit Enter.
At the prompt type ipv6 uninstall, then hit Enter.
A reboot will be required for the changes to take affect

  ERKA 13:44 06 Nov 2007

thanks ambra4 i googled and i found out i had to run it as aministator when i did this i was able to disable the above,however after this in the task manager things were as before but after a while (browsing the internet) i checked the task manager and everything had droped down ie cpu usagedown to 7% and network utilization to 2% i am going to reboot and see what happens, do i still need to unistall ipv6?

  ERKA 13:59 06 Nov 2007

i have rebooted and everything is high usage again,tried to uninstall ipv6 and message saying not recognised as internal or external file,does this mean it is not installed?

  ambra4 14:15 06 Nov 2007

#does this mean it is not installed?#

Yes, so no need to worry about it

Glad to hear all back to normal

  The 12th Man 16:54 06 Nov 2007

Right click the "Command Prompt" icon under Accessories and select "Run as Administrator".

Then try disabling the auto tune level.

Good luck.

  JChen 01:51 10 Nov 2007


I got a question. I have been trying to connect an XP to an ADSL router at home, but failed at all attempts to connect to the Internet.

Below are the methods that I have used:

1. I have used DHCP to automatically get IP address, but can not get any IP address through this method.

2. I have used a known-working fixed IP address and known server address, so it is now connected to the network, but it only sends packets but receives NO reply. In fact, it fails to ping the server.

The network adaptor is “Microsoft Loopback Adaptor”. This adaptor is typically used for VPN, but can it be used to connect to the home network?

Perhaps it can not?? So I have uninstalled it from the machine. However, upon reboot, no other network adaptor has been found, and no connection has been automatically set up.

I have tried all sorts of things, but no luck. Any advice?

Many thanks,

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires