network os mismatch, help needed

  eric_bloodaxe 10:28 26 Feb 2012

Hi: below is the text I posted to HP forums with no result.

PSC 1510 all in one printer. usb to pc running xp home sp3 32 bit. kaspersky internet security running. laptop connects wirelessly via netgear home router(WNR200 v2). laptop runs W7 ultimate 32 bit. and also runs KIS suite. at first laptop could print to 1510 no bother now it can see printer but nothing will print. message; printer is offline. hp diagnostic says printer not connected. it is connected and is visible on bothcomputers. so q is what is going on? i have tried closing security to no avail. I wonder if the problem lies in the OS mis match. I have tried changing workgroup names and computer names closing security allowing the printer expressly etc to no avail. can anyone explain a. is it practical to network this setup given the OS mismatch( even tho' the system did work fine at first) and b. if so give me some sort of step by step checklist? the laptop is sharing the internet connection fine just none of the resources on the PC. Regatrds Nigel

  robin_x 10:48 26 Feb 2012

Try Start Run services.msc and restart the Print Spoolers.

My PC with USB printer is upstairs, laptop downstairs.

Initially PC was XP and laptop W7. I don't think that's your problem.

They are both W7 now, but occasionally laptop won't print. Restarting my spooler works.

If you still have problems, do you have any recent restore points you can try from when it worked? In case a Windows Upgrade messed something up.

  robin_x 10:49 26 Feb 2012

*Update not Upgrade, of course.

  eric_bloodaxe 17:35 27 Feb 2012

Hi; thanks, but I tried that to no avail. Actually the problem is not just the printer I realise. The situation is that the W7 laptop can ping the gateway(router) and the PC (XP) but doesn't find it or the printer when asked to show network places. The PC cannot ping the laptop but can ping the gateway. however the laptop shows in network places! any attempt to access it yields an error message " \sharonpc not accessible. contact administrator, pathway not found". the account being used is an administrator one. As far as i can tell the required ports are open. Regards EB

  KRONOS the First 18:49 27 Feb 2012

This will be of no help to you but my one and only HP printer has been nothing but a pain in the rear end to network and HP's customer service is/was worse than useless. I have a Samsung laser printer and was simplicity itself to set up. I have finally given up on the HP and gone back to my usual brand Epsom.

I expect you have tried uninstall and reinstall just the drivers as I found it seem to behave a little better if I did not install all the bloat ware that comes with a HP printer.

  eric_bloodaxe 19:20 28 Feb 2012

Hi; Weird thing is that the set up did work for a while but now has stopped. Which may support the update idea but, exactly when I don't know. Chronus, I have realised that it isn't in all likelihood the printer, but the whole setup as I explained above. The evidence tends to suggest the router isn't forwarding packets internally. Is there anything one can do in that case? Regards EB

  Ashrich 23:23 28 Feb 2012

Have you tried temporarily turning off the firewalls on both PC's ? That sometimes helps .


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?