Network Hard Drive

  Dekka123 17:08 07 Aug 2010

I have just purchased an Iomega External netwok hard drive. I am running Windows XP and Virgin broadband. When I tried to instal it I conected the power and the network cable and the drive came on. I installed the software which went OK but when it searched for the device I kept getting the message no device found. My mate trid to instal it on his comp and it installed perfectly without any trouble. I am using a Belkin wireless cable router and he is not. Does anybody have any idea what the problem might be. Do you think it could be the router. Please help I am desperate. Thanks in advance.

  mgmcc 17:40 07 Aug 2010

It could be an IP addressing issue. The Belkin Router's IP address will almost certainly be and so the network drive needs to have an address in the same Subnet, i.e. a 192.168.2.x address. If it gets its address automatically from the Router by DHCP, then this should be OK but, if its address has to be configured manually, it needs an address that isn't already in use between and, with the Subnet Mask address of

When your mate installed it with his Router, it is possible that it just happened to use the same Subnet as the Router, possibly 192.168.0.x or 192.168.1.x, which are more commonly used Subnets than Belkin's 192.168.2.x - not that that's a problem, I run my network with 192.168.5.x addresses.

  Dekka123 18:26 07 Aug 2010

Thanks very much mgmcc for your speedy reply. My mate cant come over until Monday and he will do the neccessary as I wouldnt know where to start. I did not want to go to the expense of buying another router if I could avoid it. Thanks very much for the advice I will let you know how I get on.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?