Network did not assign a network address to the co

  QUADDRA 16:10 15 Jul 2007

Network did not assign a network address to the computer

Any Ideas? Trying to set up a home network just for the kids pc and mine (both desktops)

PC1 Windows XP
Zone Alarm Firewall
Avast antivirus

PC2 Windows 98
Kerio Firewall
Avast antivirus

Wireless set-up
Belkin G+ MIMO Router
Belkin G+ MIMO USB Adapter for XP PC (Desktop)
Belkin G USB Adapter for W98 PC (Desktop)

I was told that I had to set up the Router with a wired connection first so I have and this works.

The XP PC works wired directly to Router
The W98 PC works with wireless Belkin G USB Adapter

I managed to connect everything wirelessly both W98 & XP pcs with WEP & router firewall disabled.

OK but I need some sort of security so enable WEP
Enter the WEP code on both Pcs the W98 works but as soon as I try to set up the XP PC wirelessly with Belkin G+ MIMO USB adapter I get the message (network did not assign a network address to the computer)

Also found that if I go to Belkins router setup and enable the routers firewall the W98 PC also fails to connect????

Any ideas?

  recap 21:59 15 Jul 2007

I would keep the XP machine wired it that is at all possible. Keep therouter Firewall enabled and disable all other firewalls.

  QUADDRA 15:30 26 Jul 2007

Hi, thanks recap,

Wireless set-up still not working properly.
You said I should disable all other firewalls! Would the router firewall be secure enough on its own?

I really wanted to set up the router on its own and link all PCs wirelessly. I need to get rid of trailing cables.

  Toffly 23:01 26 Jul 2007

The router firewall will be more than capable of keeping nasties out, I haven't used a software firewall in years.

Just make sure the kids stay on the 98 machine :)

  QUADDRA 23:24 26 Jul 2007

Thanks Toffly.
I know exactly what you mean about the kids, that’s one of the main reasons for buying the router -so they can stay on the 98 PC. I don’t know exactly what they do but since they started using my PC on Cartoon Network, Bebo etc I’ve had loads of stupid little problems with PC faults and error messages to Microsoft. Maybe unconnected but seems a bit of a coincidence.
So would it be sensible to dump Zone Alarm on XP and the Kerio Firewall on the 98 PC? Do you think this could be the problem?

  BurrWalnut 16:52 30 Jul 2007

Sometimes typing the WEP/WPA key in hexadecimal rather than as characters solves the 'acquiring...' problem, i.e. type in 26 hexadecimal digits that represent the 13 characters.

  Toffly 20:46 31 Jul 2007

The routers firewall should more than sufficent to protect your computer, and it'll also stop the kids getting all the pop ups everywhere telling them that ajsdhfksdf.exe is trying to access the net and should they allow it.

And yes, I do feel that they could be causing the problem, but the only way to find out is to remove them.

Just remember to run crap cleaner click here to make sure that all references to the programs are removed from your system.

  QUADDRA 01:48 01 Aug 2007

Hi Toffly, BurrWalnut,

I didn’t say before but I have been typing the WEP key in hexadecimal (26 digits). Tried belkin help line some time ago and they told me not to use the pass-code but type in the full 26 digit hex code so I have been doing this pretty much from the start. Still no good.

Hi Toffly, Thanks for advice,

Yes ran ccleaner but no difference
It still won’t work…

Run mouse pointer over wireless USB icon at in task bar and it displays
Wireless network connection
Speed 54.0Mbps
Signal strength excellent
Status connected

However, if you try to open Explorer or e-mail it fails and says you are not connected to the internet?

Tried the WINDOWS WIRELESS NETWORK CONNECTION just to see what it would do and…
Windows could not finish repairing the problem because the following action cannot be completed RENEWING YOUR IP ADDRESS
For assistance, contact the person who manages your network.


So now this has just confused me more.----

My son has a PSP so thought Id see if the wireless part of it would work and can you believe it, it does! First, time no problems at all!

Does this help in diagnosing the problem?

Thanks for all your help

  BurrWalnut 07:10 01 Aug 2007

Sometimes this works click here

  Toffly 17:59 01 Aug 2007


Well, if the PSP works, then we know the router is fine, it's XP being a pain.

I'd try removing any wireless connection software that came with the card, and just use windows to manage the connection.

When you get that error, try doing ipconfig /all

Start > run, type cmd, and hit enter, you should get a black box (the command prompt)

Now just type ipconfig /all and copy and paste the results to here. You'll have to right click on the command prompt and click mark before you can select anything. Once you've selected everything, press ctrl+C to copy it to the clipboard, and use ctrl+V to paste it back to the forums.

  QUADDRA 00:31 02 Aug 2007


First tried the winsock xp fix from BurrWalnut, thanks BurrWalnut. ran the winsock xp fix internet stopped working for about 15 minutes but now has sorted itself out “pheww” tried the wireless connection but still wont work.

Second … Hi Toffly did the Start > run, type cmd thing got the black box typed ipconfig /all as you say and lots of details but for some reason when I did the ctrl+C to copy it to the clipboard, and use ctrl+V to paste it back to the forums it would not work. Any idea what Im doing wrong?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?