Network controller problem.

  phono 00:46 03 Oct 2005

First of all apologies for the lengthy post, I am trying to provide as much info as possible, anyway, here goes.

I recently installed a combo TV tuner, video capture card and a new sound card in my home built computer and since then I now have a network controller device showing in device manager with a yellow question mark beside it.

On checking it states that no drivers have been installed for the device in question, the Device Instance ID is given as PCI\VEN_1106&DEV_D104&SUBSYS_D1041106&REV_00\3&13C0B0C5&0&85.

I have deduced from the Vendor HEX code that the device in question is a VIA product and this is where the problem lies.

My mobo has a VIA chipset with onboard LAN via, no pun intended, a VT6103 PHY chip, device manager shows a VIA Rhine II fast ethernet adapter working properly and indeed my network and Internet connections are both working fine.

I have tried various drivers to get rid of the problem network controller without success, I have even disabled the onboard LAN device and windows still tries to install a driver for it, I have ticked the checkbox to stop windows asking for the drivers for the device but it is really annoying me, I suspect it may be a registry problem but I am not sure.

I realise that a format and complete reinstall may cure the problem but it would not be worth "the pain" that would entail.

Can anybody shed any light on this problem? I have checked the VIA Arena website without any luck so far.

  Batch 17:51 03 Oct 2005

As everything seems to be working OK, you could try going into the device properties and disabling it (e.g. for the current hardware profile). Then when you reboot it shouldn't appear and shouldn't be available.

If all still works OK it sounds like a phantom device, but I know that still doesn't explain how it got there.

  phono 19:38 03 Oct 2005

I will give your suggestion a try and see what happens.

Everything is working fine, it's just bugging me as to where this phantom network controller has come from, it really baffles me that when I disable the onboard LAN windows still shows the phantom controller in device manager and still looks for a device driver unless I "tell" windows not to prompt me to install the drivers.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?