Network Card Faulty?

  m800afc 17:35 14 Jun 2008
Locked

Win XP Pro, SP2,
ASRock 775VM800

I am unable to connect to the internet on my Desktop. My laptop connects perfectly, both wired and wireless.
The chap at O2 checked everything remotely and said it was probably my network card, and I should contact my computer manufacturer. How can I check, myself, to verify that the card is/is not working?
If it is not working what are the important things to look for when sourcing a new card? I am happy for my desktop to use an ethernet wired connection.

  MarvintheAndroid 18:18 14 Jun 2008

Need more info.

What are you connecting the PC to - router ? If so, are you able to access the router settings menu ?

Is your pc standalone, or part of a home network? If the latter, can you see the other machine(s) ?

Are you currently using wired or wireless ? If wired, have you tried a different cable ? In my experience, network cards are pretty reliable but cables can fail unexpecredly.

Are you getting any carrier or signal lights on the network card or at the other end ?

Write back with more.

Marv

  chub_tor 18:29 14 Jun 2008

From looking at your motherboard spec it has built in LAN, is that what you are using as a wired connection to your router?

You can check if it is working by looking in Device Manager (Right Click My Computer, then click on Properties) and see if it has a yellow question mark or Exclamation Mark over Network Adapters.

If you have a separate wireless card plugged into a PCI slot you can also check that in the same way.

  m800afc 18:55 14 Jun 2008

The PC is connected by ethernet cable to the router, which was supplied by O2. The router, which has no model number, is labled "O2 Wireless Box". I have tried changing the ethernet cable, and have tried all the router ethernet sockets in turn. The O2 chap tried a remote repair, which included pinging Google (timed out four times), updating firmware and reinstalling software from The supplied O2 disc. I have also disconnected the router from the mains, and left it for 30 minutes before trying again. All of the LEDs on the router are working correctly, and I can use the laptop wirelessly and with the ethernet cable which is normally connected to the PC. I have tried renewing the Desktop IP address, to no avail. The network card is listed as a VIA Compatable Fast Ethernet Adapter, which, according to the device manager, is "Working Properly". The device location is "PCI bus 0, device 18, function 0". I am guessing, but does PCI bus 0 mean it is on the MOBO and not actually a PCI card? If so, what is to be done?

  m800afc 18:56 14 Jun 2008

Sorry, forgot to mention, the LAN icon does have a yellow triangle on it.

  chub_tor 20:19 14 Jun 2008

From the sounds of it the router is working OK if you can successfully connect to it with your laptop.

The Ethernet adapter device location being PCI bus 0 does not mean that it is a seperate device in a PCI slot it just means that it is on the PCI bus and so it is probably the one on the motherboard, you can tell by looking at the back of the PC, if the ethernet connector is close to the line of other mainboard sockets (USB, PS2, Sound etc) it is almost certainly on board.

The LAN icon has a yellow triangle - is that shown in Device Manager or in Network connections?

  m800afc 21:46 14 Jun 2008

The ethernet socket is grouped with the other motherboard sockets, so I assume it is on the MOBO. The yellow triangle is on the Local Area Connections icon in the Network Connection Folder.

  chub_tor 22:04 14 Jun 2008

OK this link click here probably explains better than I can as to how you may be able to correct the LAN yellow triangle problem.

As I said earlier you may get a more detailed answer by posting this question in the Network Forum.

  MarvintheAndroid 08:41 15 Jun 2008

This sounds like a resource conflict. A few things you could try :

Check your BIOS is set to Plug and Play OS - otherwise your BIOS will be trying to reserve resources when Windows is already doing the job.

While you are there, make sure that on-board devices such as modem / parallel port / serial port / floppy disk are disabled in BIOS if you are not using them.

Also, what other PCI devices are you using, try removing or disabling other PCI devices to see if that frees up enough resources.

Is this a new system, has it ever worked or has it been u/s since you had it ? Did you get it brand new or second hand ? Manufactured or self-built ?

Marv

  MarvintheAndroid 08:46 15 Jun 2008

Just re-read the post and noticed the yellow triangle is not in device manager - so ignore what I said.

Marv.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?