Network Address

  JohnC123 16:37 02 Oct 2005

I have a wireless network D-Link G604T.
One laptop which I have recently upgraded to Windows XP-Home refuses to connect to the network - the signal strength is described as 'excellent' but it just hangs on 'acquiring network address' Previously it acuired a network address from APIPA which I have now disabled.
The other two laptops in my network connect instantly and properly. Any help in resolving this will be greatly appreciated.
For info: the router is connected to my main pc by ethernet, the other laptops connect by wireless. All are on Windows XP

  scotty 19:57 02 Oct 2005

The pc must get an address from somewhere, such as by DCHP from the router or by it being assigned a fixed address. It sounds as if the problem pc does not have a fixed address nor is it being assigned one by the router.

Do you know how the other pcs are setup to obtain addresses?

Have you tried running the wireless network wizard?

  JohnC123 20:13 02 Oct 2005

The other computers in the network are assigned their IP addresses by the DCHP server in the router.All of them are set to find their IP Address automatically. They have no problem connecting to the network. The problem laptop used to assign itself an IP address from the APIPA but I did the recommended registry fix to stop it doing that. Even this laptop will connect to another wireless network but not to mine which makes me think the problem lies in the network set up.
I initially set up the network using windows wireless network wizard.

  mgmcc 22:41 02 Oct 2005

Presumably you haven't enabled encryption, or MAC address filtering, in the router's Wireless Access Point so that it is now blocking access to that one WiFi adapter?

  scotty 12:35 03 Oct 2005

I would be tempted to restore computer to a date before you made the registry changes then run the wizard again.

  JohnC123 18:20 03 Oct 2005

Sorry for the delay in responding.
I am now in an hotel in Surrey, connected, with the problem laptop, to their wireless network with no difficulty whatsoever. It therefore seems the problem is in the settings of the router which, of course is at home , so I'll need to leave this thread open until next weekend when I can try again.
Maybe the best thing to do is to put the router back to its factory settings and start again to make a new network ?? Any thoughts on this ??

  Diver14 19:07 03 Oct 2005

I've just had an identical problem on a new setup wired the same as yours.

I spoke to the tech chaps who make the router (Ozenda) and they recommended I change from "auto" on the channel selector and pick a channel at random until I found one that worked. They stated interference as the most likely cause. It worked as I am now on the laptop in my lounge connected at full speed.

  JohnC123 19:12 03 Oct 2005

Diver14 Thanks for the tip, I'll give it a try when I get back home.

  JohnC123 10:01 09 Oct 2005

I'm still completely baffled by this wireless network. All last week when I was away, my laptop connected with no problems to the hotel's wireless network. As soon as I return home it will no longer connect. Sometimes it finds the wireless network and then tells me theres no connection with the server - at other times it just locks on acquiring network address". The other two laptops in my network connect instantly as soon as they are switched on. I hesitate to disable the network in case the others do the same as the older laptop. (I tried Driver 14's tip - still no good )

  scotty 10:27 09 Oct 2005

Taking things one step at a time -

It sounds as if your hardware is working as you state you state the problem laptop receives an excellent signal. Just to confirm this link is working, try PINGing the router. Goto Start\Run and type cmd then in the command prompt window type PING (replacing the numbers with the IP address of the router if different). This command will come back with either times for the packets to be received or a message saying packets were lost.

Next, in the command prompt window, type ipconfig /all. This will give information about the IP configuration for your laptop. Post back with the IP address, if DHCP is enabled and the address of the DHCP server.

  JohnC123 10:50 09 Oct 2005

Good Morning Scotty
I tried pinging the router - it says "Destination host unreachable"
Packets sent 4 received 0 lost = 4 (100%)

This is whilst it is still saying "acquiring network address"

Config / all gives

Host name = Oldlaptop
Primary DNS SUffix ....
Mode type Broadcast
IP Routeing enable N0
WINS Proxy enabled NO
ethernet adapter wireless network connection No 6
Physical address 00-11-95-48-C5-E0
dhcp enabled yes
Autoconfiguration enables yes
IP Address
Subnet mask
Default gateway ....
DHCP Server

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017