Network Adaptors Problem

  Charlie Babbage 17:28 16 Oct 2008

Firstly, please see my previous post regarding virus removal click here

The last remaining problem is that I cannot get an internet connection. The wireless modem is Office Connect ADSL 11 g Firewall Router and connects to the computer via an ethernet cable.

In Device Manager, under Network Connections, the following all have yellow exclamation marks but cannot be uninstalled / reinstalled even when the modem is on because an error message states 'Failed to uninstall the device. The device may be required to boot up the computer':

WAN Miniport (IP)
WAN Miniport (IP) Packet
WAN Scheduler Miniport
WAN Miniport (L2TP)
WAN Miniport (PPPOE)
WAN Miniport (PPTP)

Does anyone know if the Office Connect wireless router should have an installation CD-ROM? If so, that can't be found at present!

If anyone can give me any ideas as to how to get this beast working again, that would be much appreciated.

  User-1300263 17:39 16 Oct 2008

hi i used to have an office connect i think it came with a disk but i never used it... if the yellow wxclamation marks are in device manager then you need to sort the driver out...

  Ashrich 22:24 16 Oct 2008

The items in Device Manager are nothing to do with the router , they need modem drivers re-installing , either from something USB you had earlier or for your current dial up one . As for not being able to get online , quite often after Virus removal the Winsock and/or TCP/IP stack can be damaged . First can you establish whether the Network Port ( ethernet ) is visible in Device Manager , if it is the go to the Start button , click on that and select " run " . In the run box type CMD and press enter . This will bring up a command prompt in a black box . type this first ( without quotes ) " netsh int ip reset resetlog.txt " press enter , then type in " netsh winsock reset catalog " press enter again . You will be told that the PC must be rebooted , type " exit " press enter , then do that again , then reboot and see if access is now there .


  Charlie Babbage 22:30 16 Oct 2008

... I'll try that tomorrow!

  Ashrich 11:40 19 Oct 2008

I have just come across this problem with a client's laptop , in his case it seems to be AVG that might be causing the problem , I am investigating the problems with the marked items in device manager , but my initial sloution at least got the PC online .


  Charlie Babbage 14:22 19 Oct 2008

I did try your suggested solution on the machine with which I have a problem. I'm not sure but, at that stage, the Network Port (ethernet) was not shown in Device Manager.

Anyway, as a 'last ditch attempt' I tried System Restore and put back the settings to a date before when the virus was detected. This SEEMS to have worked - was that good luck or judgment?? I can now get an internet connection and email is being received.

I do hope that you can solve your problem quickly. You are certainly more knowledgeable than me so good luck!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?