netsh command & startup

  HappyTrucker 14:51 24 May 2008
Locked

Hi all, not been here for a (long) while but hopefully that won't go against me!

This may be a bit outside the normal scope of this forum, but I'll have a go and see what comes up.

Like a lot of people I've found that copying files across a network via Vista is woefully slow and laborious. Usually maxing at 1.5 Megabytes/s (about 15 Megabits/s I think) even on a wired connection. This was often worse via wireless, maybe 1Meg/s or less.

After a lot of searching I found the fixes that can be applied using the NETSH command at a cmd window and this seems to have improved things a great deal. Wired transfers are now at about 5 Megs/s (50Megabits/s) or about 50% of the actual connection rate. Not as fast as XP yet, but a lot better.

My problem is this - my main desktop PC (Vista Ultimate) seems to reset the netsh settings to their defaults each time the PC is booted. Now to run the netsh SET commands you need an Administrator cmd window. I've tried using a batch file at startup to run the NETSH command I need to set the values to the ones I need but due to needing an elevated cmd this just fails.

Does anyone know of any way to get a batch file to run with full administrator rights? My user account is an Administrator but for some reason in Vista this doesn't seem to do it. It seems there's an ADMINISTRATOR who's higher than a User/Administrator.

Hope this was clear enough, and hopefully someone'll be able to point me in the right direction.

  [email protected] 14:58 24 May 2008

a bit confused as i would have thought right click run as admin on command prompt would have worked.
it's all here click here

  HappyTrucker 15:56 24 May 2008

Hi adman,

Right clicking etc does work, but I want the batch file that calls the command to run automatically at start up without having to manually type the overlong DOS command each and every time I boot.

Would disabling the UAC help with this or would I still need to use an elevated cmd prompt to run a batch file that sets values in the netsh environment?

  HappyTrucker 16:41 24 May 2008

Ah, might have sorted it. I had to create a Task to run at logon and allow that task to run with highest privileges. Seems to allow me to set the netsh values

I tried disabling the UAC but the balloon popup got on my nerves....

Thanks anyway

  [email protected] 16:53 24 May 2008

if you use true admin you wont get pop ups, if you stay as you are use click here on quiet mode.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires