Netbook Windows update service not running

  Ikarus 15:09 23 Jul 2012
Locked

I have a netbook with 2Gb of memory which originally ran Win 7 Starter Edition. I bought the Anytime Upgrade, installed it and, up to three months ago, got Windows updates. Then, suddenly, when clicking on Windows Update I got the message "Windows cannot update because the service is not running. You may have to restart your computer". I have run Microsoft's troubleshooter which reports all problems solved but I still get the same message when trying to update. Is there a solution to this please? I have no problems with my desktop computer.

  KRONOS the First 15:15 23 Jul 2012

Some steps to follow here. Microsoft.

  birdface 15:16 23 Jul 2012

Have you gone into services and made sure Windows Update is set to automatic and running.

  Ikarus 09:05 24 Jul 2012

Thanks to both of you for replying. Buteman, yes I went into services and it showed Win Update as running and auto start but it didn't work. Eventually I used one of the suggestions in the M/Soft solutions suggested by Chronus i.e. go to "services", find the " SoftwareDistribution" folder, delete it then go to Windows Update, click on it and download a new version of the programme. I then updated in the normal way and all worked perfectly. Thanks again.

  KRONOS the First 09:08 24 Jul 2012

Glad to hear it. If you want to click on the tick to the right it will turn green and indicate a resolution to the problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)