.NET performance counters on this system corrupt

  malcolmv24 09:13 17 May 2008

My PC is dual boot with windows XP on both partitions. One is used for work and the other for games. I recently had a problem with the work partition and used Sysinternals Process Explorer and this helped me solve the memory problem. However when I used it on the games partition I received the message "The .NET performance counters on this system are corrupt. Run Exctrlst from the Microsoft Windows Resource Kit to repair them."

I have run Exctrlst by going to the command prompt but I have to admit defeat here and I really hope that someone can help. I didn't know I had a problem until I ran Process Explorer and the only real evidence of a problem that I can see is when I log into my Netgear DG834v3 modem and it takes ages to show the configuration screens whilst in my work partition access is instantaneous. My browser is Mozilla

Looking forward to any help available

  Earthsea 14:42 17 May 2008

click here any help?

  malcolmv24 20:58 20 May 2008

Thanks Earthsea - I had previously found this link but could not get it too work. However must have mistyped something as error message for Sysinternals Process Explorer has gone. However logging into modem is still slow. Very fast on main system but extremely slow on games partition

If anyone can suggest where to start looking I would be very grateful

  brundle 23:24 20 May 2008

Don't confuse .NET with "the internet" or any network related stuff, they are two different things. Your slow router log-in is caused by some other issue with the network settings on the games partition.

Clear temporary internet files; click here
Try with firewall disabled.

Reset TCP/IP; netsh interface ip reset >c:\resetlog.txt
Reset Winsock; netsh winsock reset catalog
Flush DNS cache; ipconfig /flushDNS

Enter the commands one after the other at the command prompt

If you're not sharing files go into the Local Aread Connection properties for the machine and untick or remove Client For Microsoft Networks and File And Printer Sharing.

  malcolmv24 10:28 07 Jun 2008

Thank you to both of you and my PC seems to be perfectly OK - both replies were of value and helped me. The link by Earthsea solved the first stage and Brundle offered a series of steps I could take thtrough which I eventually realised that the problem was Child Protection in Laspersky. How it got turned on is a mystery but no problems now.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?