Net Objects MX wont Publish

  geoff47 02:13 25 Mar 2005

I have designed a website and am trying to test it by loading to my free webspace on NTL.
The problem now is that when I choose to Publish it some items say "Never Published" what ever I do.I have tried to Publish Locally and then Remote and believe I am doing everything alright....any advice would be appreciated.
Thanks Geoff47

  geoff47 02:30 25 Mar 2005

When trying to publish it says "Unable to set the base directory"
I have "published" an earlier version but now my home page shows a simple index page that only takes me back to the NTL web site.
I am sure it is soooo simple ...but so am I.
Thanks again.

  Pesala 12:12 25 Mar 2005

Check the Properties on the Page management tab.

Go to site view, select each page on the outline view, and on the properties palette, click the management tab. See if the box "don't publish" is checked.

  geoff47 12:55 25 Mar 2005

Have done that ...None of them have that box checked.
It has Index.HTML and the others going down the left hand pane.The first is Page Name Index.Html and Page title the same....then the others.
In the right hand pane it has Child Name with the page name...Page Type "Normal"...Status "Not done" and then Publish "Yes"

Any clues what I am doing wrong from that imformation?....hope it is clear.
Thanks Geoff47

  Pesala 13:09 25 Mar 2005

Maybe someone else can help.
Have you setup a publish profile on the publish site, publish settings dialogue? (Click the pencil icon).

Enter for the host, enter a directory┬╣ for your site, your username, and password.

┬╣ You don't have to enter a directory, but it is useful if you want to publish different sites on the same webspace.

  geoff47 13:24 25 Mar 2005

I dont want to Publish different sites ...just alter the one that was there...I only put it up to see if I I want to get serious.
When trying to access "My Site" all I am getting is a Page with variuos blue links the only one that works is back to NTL.
Perhaps that is enough to show how little I know.

Just enjoyed a cheese sarney while writing made me remember I was hunry.


  geoff47 02:56 26 Mar 2005

I have been on and off all day working on my latest project.

I have built a site in NetObjects Fusion MX as recomended by this forum and tried in vain to upload it.I used a shareware version of Terrapin a freebie for 30 days from NTL to upload to "my web space"

It was a shambles.....some parts displayed...others didn't.Tried again with NOF MX and it said the upload was succesful....after a few alterations of the settings to get it going.

Anyway the bottom line is its still a shambles....take a look and please let me know what I can do to sort it out.....if its not beyond repair.

click here

Thanks for any help.

  geoff47 12:30 26 Mar 2005

When you say "start again" do you mean scrap everything and start again?
I have designed the site with Nof MX and see everything OK on my PC,where have I gone wrong from that point foreward....or when did I start going wrong?
As far as I am concerned I have doodled with the program and when it was "nice" enough uploaded the product.
Is my progam faulty? or is the problem with my "cavalier" use of it?
Thanks for your succint evaluation"technically rubbish".....its the why? I need to know now.
I used a WYSIWYG program because I know my limitations
Any tips Please....Geoff47

  geoff47 19:57 26 Mar 2005

Thanks for that ....I am sure I had been advised to use frames....but while saying that with a program like Nof mx all I do is enter items where I think they look right...edit the display and then the program takes over....or so I thought.
Perhaps I am not going through the correct procedures within the looks OK on my PC though.

I will tinker around and see what I can do first,before srapping it completely.

  Forum Editor 00:15 27 Mar 2005

I agree that it would be better not to use frames, but let's leave that for the moment.

I note that you transferred the site to the NTL server using an FTP program (Terrapin) - why did you do that? What you should have done is to use NetObjects Fusion itself to publish the site from the start. You're not alone - many people try to use an FTP program and forget to upload everything that's needed, like images for instance, or hyperlinked files like Word documents or PDF files.

The advantage of publishing from NOF is that the program will automatically ensure that all images and other files are collected into the site's assets directory during the publish sequence, and these will go to the server in the correct way - using the appropriate file transfer protocol in the case of images. The NTL server is telling my browser that it can't find the filename. I can see the index.html page in your username directory, but the other pages can't be found. This might be because they aren't inside the html folder in your root directory.

It's difficult to diagnose without seeing the server directories - if you fancy sending me your NTL login details via email I'll gladly take a look and let you know what's wrong, although I'll quite understand if you prefer not to do this.

  geoff47 05:14 27 Mar 2005

I have had another bash at this whole thing.Ditched the earlier site and started from scratch as recomended earlier.
Now I am getting a message when trying to upload.It says words to the effect "C Protocol not recognised"
I am now trying to use NOF to publish
I used Terrapin before because NOF was not uploading,possibly because of the errors that have shown up when it was transferred.
I know when I grasp this I will kick myself.
Thanks again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017