.net framework - how do I know if I have it?

  six-h 01:21 25 Aug 2007
Locked

I've just tried to install "youtube-d" to grab streamed video, and it won't install as it says I need to install a version of the .net framework.
I have a feeling that I already have this, and tried "Search" for "dotnetflv.exe", but found nothing.
How can I confirm if I have it or not?

  Thalmus 01:28 25 Aug 2007

Look in add/remove programs in control panel. Or you can goto Windows updates and see if it is an optional update listed there.

  six-h 01:47 25 Aug 2007

Thanks Thalmus,
Can't see it in Add/Remove, although almost all the windows updates/hotfixes/patches, are only identified by KB numbers or other reference numbers.
I thought it came as part of the SP2 pack for XP, Which is what I'm running.
The MS "home" site only serves to confound me totally!

  six-h 02:08 25 Aug 2007

Thalmus,
More news, I've just discovered the "review your history" page of MS updates site!
It shows that on May 27th, MS updates installed the .netframework version 1.1 service pack 1 sucessfully.
But on the same date Auto updates failed to install a security update for the above: - reference KB 886903.
It shows a red button with a white X on it, and a yellow "?"
Any ideas how to go about re trying it, or finding out why it failed to install?

  six-h 02:51 25 Aug 2007

Totally bewildered! Unless I've missed something
whilst wading through the Microsoft maze, I can only find very user unfriendly instructions on how I can correct their mistake.
Aparently, error code 0x643 refers to a conflict with an earlier update, involving script changes in Sys 32 folder and registry editing, which I'm not prepared to do. I am not qualified or confident enough to undertake this, and cannot believe that MS. can expect home users to clear up their mess in this way.
Am I being unreasonable??

  Stuartli 11:11 25 Aug 2007

If you go to Add/Remove Programs and Remove the iNETFramework version listed, you can then go to:

click here

and download Version 2.0 (most likely the x86 download).

  Stuartli 12:16 25 Aug 2007

Another download source:

click here

  six-h 17:11 25 Aug 2007

Nice try Stuartli, but Add/Remove doesn't list ".net Framework v 1.1 service pack 1" as having been installed!!
The MS Update site > Review your history, lists it as installed sucessfully on the 27th May.
It also lists two security up dates to it, on the same day, one of which failed.
I notice that both security updates bear the same number, KB886903.
I have a sneaking suspicion that these are one and the same.
Talk about TMI !
However, if that is in fact the case, it leaves me with two more questions: -

Why doesn't Add/remove admit to having received the ".net Framework v 1.1 service pack 1",or likewise, the update thereto, KB886903 ?

Why did the software I downloaded detect that I needed to download and install the ".net framework before it would install?

  woodchip 17:18 25 Aug 2007

Type in Search, "net framework" see what it finds

  Stuartli 17:41 25 Aug 2007

>>Nice try Stuartli, but Add/Remove doesn't list ".net Framework v 1.1 service pack 1" as having been installed!!>>

It's hardly a nice try.

Control Panel>Add/Remove Programs lists Versions 2.0 and 3.0 being installed on my system.

There was some confusion back in July regarding updates/patches for iNET Framework and, in mine and others' case, the best thing to do was completely uninstall iNET Framework and download the two latest versions.

I would Remove the Updates and install the latest version (Version 2.0 may well prove sufficient).

  six-h 18:05 25 Aug 2007

Stuartli,
I think something is being lost in the translation, You are typing "iNET Framework"
I thought it may have been a typo, as I've never heard of this, and my problem concerns the ".net Framework" (as in "dot" net...), but since you persist, I cannot believe it is a typo after all.
What is iNET?
woodchip,
Done that and surprised that it found 2 shortcuts, both stored in the same location, C\docs&settings\all users\start menu\progs\admin tools.
Funny thing is they are dated 15/10/03 (presumably the date the disc was immaged by Medion during manufacture)
Updates site recons they succesfully dinstalled the .net Framework onto my machine 27/5/07,
so why is it that the shortcut exists three and a half years before the program? And why is it not found by either Add/Remove progs, or the search I just made?
Im confused!!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?