Net framework 3.0 service pack 1 fails to install

  jay65gee 19:27 25 Mar 2008
Locked

Please help.
I am running XP Home SP2 and over the last few months have had problems with updates to net framework 2 & 3 failing to install.
Currently windows update tries daily to install net framework 3, service pack 1 (KB 929300).
Downloading is not a problem the failure only occurs on trying to install the update.

The log entry shows:

[03/25/08,18:12:20] Microsoft .NET Framework 2.0: [2] Error: Installation failed for component Microsoft .NET Framework 2.0. MSI returned error code 1603
[03/25/08,18:13:38] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0 is not installed.
[03/25/08,18:13:38] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.

Checking back via control panel/add-remove programmes I can see that:
(1) Net framework 2.0 has had a security update (KB928365) with service pack 1 installed.

2) Net framework 3 has a hot fix KB 932471 installed.

I don't understand what has gone wrong and what remedial action I need to take.

Can someone assist?

Many thanks

JayGee

  BurrWalnut 19:31 25 Mar 2008

Have a look click here

  jay65gee 19:38 26 Mar 2008

Many thanks BurrWalnut, problem now resolved.
Your link pointed me in the right direction.

I think that the original updated installations were corrupt and that although appearing in the control panel add/remove programmes I couldn't uninstall.
Microsoft's own removal tool didn't help.

I found another reader with a similar issue and the solution was to download Aaron Stebner's removal tool. This did the trick and having uninstalled the faulty programmes I have been able to download and reinstall.

Thanks again

JayGee

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires