.Net framework

  bluto1 22:31 12 Apr 2007
Locked

Evening all, at last,
Whilst doing a spring clean on my PC I found, in add/remove,
M/S .Net Framework 1.1 (and a hotfix)
M/S .Net Framework 2
and M/s .Net Framework 3

Do I need all of these or can I delete the first two? Any help appreciated.

  skidzy 22:37 12 Apr 2007

Im a little surprised you have version 3 Bluto,this is aimed at software developers.

I would not remove them due to the fact some software needs the earlier versions to run.Not all software is compatible with NetFramework 2.0 so 1.1 is needed.

  birdface 22:37 12 Apr 2007

Safer to keep them all,

  birdface 22:40 12 Apr 2007

Hi Skidzy I got version 3 with normal microsoft downloads,As it was from them I automatically downloaded it.

  skidzy 22:48 12 Apr 2007

So it has downloaded,and thats on my Vista machine,will check the others tomorrow,thankyou.
Regarding of them all...keep them.

  bluto1 22:50 12 Apr 2007

I`m the same as buteman, Normal download from M/S so I installed it. Probably a careless thing to do but it`s done. I`ll take the advice and leave them. They appear not to take up any space, so it won`t matter.
Thanks for the input guys, appreciated.

  skidzy 22:50 12 Apr 2007

I can only assume that some newer software requires Netframework 3.0 now,i havnt researched this,but did have a readup a while back.
I guess MS would not have sent it out unless needed.

  anskyber 22:51 12 Apr 2007

It come automatically with Vista.

  skidzy 22:56 12 Apr 2007

anskyber,cheers for the confirmation regarding Vista.

  Stuartli 23:48 12 Apr 2007

I also have iNETFramework 2.0 and the earlier versions, plus a patch, on my system.

Presumably there is a reason for it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Adobe shows still-in-development tools, including automatically colourising black-and-white photos

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?