need to alter recovery disc to make it work

  jolorna 10:19 08 Feb 2003

i have a advent which uses a floppy disc & cd a new cd rom drive has been fitted so when i try to reformat the computer the floppy works so far it shows the name and driver for the old cd rom drive then it says no cd drivers installed which prevents the recovery cd from working, listed on the floppy disc are the following.
autoexec, choice, command, emm386, keyb, mscdex, warnings.

  Rtus 10:42 08 Feb 2003

usually the recovery disc uses a generic driver (so it doesnt matter which replacment type is fitted ).as does W98 startup disc..The drives initialised by the autoexec entry \MSCDEX.EXE /D:mscd001 /L:%CDROM% command (or similar)if you look at the part D: + location found ..the mscd001 refers to the drive being slave .you can alter this to mscd000 for master setting if thats where the drive is actually installed.. you need to ensure both the Config.sys and Autoexec.bat files agree on entries to make this work ..So best way is make a flopy copy of the original then modify to suit..if your not sure email me via yellow env <<

  TECHNODIMWIT 10:45 08 Feb 2003

try making a copy of your recovery floppy.
check it starts the pc.

make a second copy from add/remove progs.

on the copy remove cd drives and substitute oakcdrom.sys from the copy made from add/remove progs.

hopefully this will give you a generic cdrom driver. if no drive came with new cdrom, you should be able to down load these from the relavant web site.

wait and see if any one else responds, as i might be talking out of my backside


  jolorna 11:19 08 Feb 2003

i have just used rtus yellow envelope i have tried swapping the mscdex with the one i downloaded from lg but it still comes up showing the old matsushita drive so either it is in one of the other ones or im doing something wrong, probably the wrong

  TECHNODIMWIT 12:10 08 Feb 2003

sorry this one has me beat,

i`m not skilled enough to play with autoexec.bat

advent like packardbell dont make life easy when components are changed


  Rtus 18:50 08 Feb 2003

I have received no email from you so far .Ive emailed your PCA address...Send a copy of the autoexec.bat and the config.sys from the recovery floppy (via atachments) Ill email you giving the correct address to use .In this case you cant send attachments via PCA forum post..So Ive provided address for you.

  Rtus 18:57 08 Feb 2003

early days are always steep learning curve however youll soon master it.In any case your not far off..

  Qmar 21:03 08 Feb 2003

just to help me (+other members?).. could you give a short scenario of what system and CD's and hardware you had before/have..what you had changed, .. and what you want to achieve.

  Rtus 21:21 08 Feb 2003

Ill update ASP its looking as if wrong entries are implimented in the autoexec (D:OEMCD001) as they dont match the config entry D:MSCD000 and it also looks as if the driver system file isnt present on the floppy.However Im awaiting confirmation and copys of files to correct them.

  jolorna 10:45 09 Feb 2003

the system is a advent 8575 p11 350mhz win 98 the system was brought with the advent setup & recovery discs which is 1 floppy & 1 cd you are supposed to put the floppy and cd in and then shut down and restart which will take you through the recovery it has always worked ok even up to the point before the matsushita cdrom drive was changed since the lg 8521b cdrom drive has been fitted the recovery procedure doesn't even reach the end of the floppy sequence

  jolorna 11:33 09 Feb 2003

sorry what i should have also said when i sent the last disc attachement when i said it has progressed further its now running in dos instead of windows

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)