Need advice on accessing old HDD's

  six-h 18:14 20 Mar 2011

I've been given severel old HDD's, three I can access:
One still has data on, one is formatted "FAT32" and one "exFAT"...don't recognise this format suspect I can re-format to NTFS?

Other ones I just can't access.
I've tried various jumper settings, and without jumpers.
System "acknowledges" when they are powered up, but they don't show in Computer.
Right clicking "Safely Remove", shows they are all connected via "comms port 3" and proclaim "This device is working correctly".
powering them down brings a message "Cannot stop device due to unknown error" "DO NOT STOP"!!
>>too late, I already have!

Any advice on how to gain access to these rogue drives?

  ams4127 18:23 20 Mar 2011

What operating system are you using?

If Win7, then go into computer management and look for the disks. You may have to make them active before you can use them.

  Nontek 18:31 20 Mar 2011

You could try a USB External Drive Caddy.

  six-h 18:42 20 Mar 2011

Sorry, Vista Ultimate, and I'm using external caddies.

  Strawballs 21:42 20 Mar 2011

Try going into the admin tools via control panel and looking in disc manager

  six-h 22:00 20 Mar 2011

Hi Strawballs, Disk Management just shows my internal Disk, no sign of this usb caddy.
I've just deleted the generic windows USB Mass storage driver that was applied to this disk, (Tried updating it first but Windows said it was current)now windows says it cannot find a suitable driver....refer to MFG.

  Strawballs 22:20 20 Mar 2011

Make sure jumpers on master for USB

  six-h 22:43 20 Mar 2011

Strawballs: I'll never understand these damned HDD's!
I've managed to communicate "normally" (where they show in Computer) with 4 of these 6 drives.
Two have the jumpers set to master, two have them set to slave!

The remaining two units which just show in device "USB Mass Storage devices", are totally unreachable, wherever the jumper is,(or isn't)!

Had to give up for tonight, try again tomorrow!

  robin_x 22:49 20 Mar 2011

Only a guess (for tomorrow).

Would the HDDs be ext2/3 Linux or Apple Mac formatted?

Would gparted help in that case to reformat to NTFS or FAT?

Make a boot CD/DVD and try Parted magic and see what it sees?

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017