my wireless mouse is broken

  mad1234 14:56 02 Jan 2008
Locked

i have a sweex wireless mouse - its the one where you plug the little reciever into the ps2 port & it sits on the table. it was working fie before xmas & when i came in this morning it was dead:(
i immediatley put a new set of batteries in it & still got nothing - it is completley dead(doornails have more life). i have looked in the manual for help but the english part is only 2 pages long
does anyone have any advise or should i give it up as a bad joke & buy a new mouse(i am using a laptop micro sized mouse & it's aching my fingers)

thanks

  anskyber 15:02 02 Jan 2008

Have you re synced the mouse after the batteries were replaced? Press the buttons on the underside of the mouse and the receiver.

  mad1234 15:05 02 Jan 2008

tried that but nothing- usually the bottom lights up red but i have nothing not even a glimmer

  MCE2K5 15:24 02 Jan 2008

Did you put the Batteries in the right way round.

  mad1234 15:32 02 Jan 2008

yes MCE2K5 first thing i checked when noting happened

  Gamer555 15:51 02 Jan 2008

Check that the PS/2 receiver is plugged in correctly.

Worth a try, it may have been knocked accidently.

  mad1234 16:08 02 Jan 2008

Gamer555 have tried that one too but even if that was unplugged the red light on the mouse would come on wouldn't it?
i'm getting nothing except for a sore hand off this tiny mouse i'm using

  mad1234 07:18 03 Jan 2008

^

  rawprawn 08:38 03 Jan 2008

Look in Device Manager and see if it's showing as a problem if so reinstall the drivers.

  mad1234 08:55 03 Jan 2008

rawprawn - no problems showing there

  rawprawn 09:46 03 Jan 2008

Looks a bit like a new mouse needed, I use a Logitech on my laptop with no problems and the batteries last ages.
click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017