My OS won't load...

  ddd3 00:12 27 Feb 2003

Right. Sorry if this reads like War & Peace, but I have no idea when this problem started or exactly what it is so I'm starting from the point where I KNOW the computer was working.

I upgraded my computer. New motherboard with AMD 1.33 cpu, 768meg of memory, ATA 100 card, and two more hard drives, a fast Seagate 80Gb and a slow Maxtor 120Gb.

W98 couldn't cope with the drives or the memory, so I upgraded to 98se, which was no better. I borrowed Wme to see if that would work, but I was still bombarded with Blue Screens of Death. I couldn't borrow XP (You know why...) so I decided to try Mandrake Linux for a couple of quid rather than give Bill more of my hard-earned.

It worked a treat and I thought my troubles were over until I took one liberty too many in superuser mode and screwed it up. No problem, I reloaded and later flashed out on a paid-for boxed edition of Mandrake9 so I could access the free help, which I promptly needed because Mandrake9 kept locking up while it was loading, but 8.1 still worked perfectly. Their solution was to insert 'ide=nodma' into the loader. It worked, but I wasn't happy about the solution and when I got the chance of another high speed drive I stuck it in and loaded M9 onto it to play about with it. Only since it wouldn't load I couldn't get to it to insert the 'ide' command so I loaded 8.1 on top of it, which I could access, but it didn't work properly, and neither did my previous loading.

To cut a long story short it got harder and harder to get the thing to run so I decided to cut my losses and start from fresh. I wiped all the discs and reloaded M9, and after the initial installation it wouldn't load again. So either there's something wrong with Mandrake Linux 9 which no one else has reported, or at some point I did something to upset my computer.

Here's the message I get when it freezes.

ide_dmaproc: chipset support ide_dma_timeout func only: 14
hde: dma_intr: bad DMA status (dma_stat=1 )
hde: dma_intr: status=0x50 {DriveReady SeekComplete }
hde: 196 bytes in FIFO

(I get this message 3 times, then the 4th time it changes to:-)

ide_dmaproc: chipset support ide_dma_timeout func only: 14
hde: dma_intr: bad DMA status (dma_stat=1 )
hde: dma_intr: status=0x50 {DriveReady SeekComplete }
hde: dma disabled
hdf: dma disabled
ide2: reset: success
/dev/ide/host2/bus0/target1/lun0: p1

(Long pause)

spurious 8259A interrupt: irq7

...and that's it. Anyone know what my computer is trying to tell me?

  Philip2 01:34 27 Feb 2003

Not much help here but your RAM is far to high for Windows 98 or ME never go above 500mg for these OS i run 250mg.
Why are you running two hard drived total 200GB well over the top for home use have you got your jumpers on the correct pins IE MASTER and slave??
Try taking one hard drive out.
There are people far more up in IT than me so they might be able to shine a light on your problems.

  MichelleC 08:11 27 Feb 2003

I'm 98se and my spec is; Athlon AMD 1.2 gb,
512 ram,
main hd 40gb (5400),
2nd hd 60gb (7200),
Ext hd 120gb (7200),
DVD 16x,
cdwr 16x 10x 40x,
1394 firewire. I have no probs so it could be ram as Philip2 says, or maybe your PSU isn't able to take it all.

  powerless 08:26 27 Feb 2003

Windows 98 is able to support RAM over 512MB but you have to make specific changes within windows to allow support of 512MB of RAM or more.

To rule out the RAM being the cause of your problem, just install 128 MB or 256 MB of RAM if you can do that.

However the messages you are recieving seem to be related to your hard discs.

But which one? Only have the one hard drive connected. Pysically remove the others.

Now i'm a windows man myself, never been near mandrake. So i'm sorry i cant offer any help with M9. Others will...

If you wish to use Windows 98 again...Do as above. Add one HDD at a time. See if anything happens.

It's also possible that one of the HDD has failed.

Are you using 40 or 80 wired IDE cables to connect the drives?

MichelleC has a good point on the PSU, what wattage is your PSU?

When you have the one HDD connected go to the device manager and select your drive and enable "DMA". Add your other drives and do the same.

I've ran out of ideas.

  powerless 08:33 27 Feb 2003

click here for the spurious 8259A interrupt: irq7

  powerless 08:40 27 Feb 2003

From what i can see on click here Those message are Linux etc related...

Windows 98 doesnt appear from what i can see...

Oh well thats me done.

(mis read your post slightly)

  ddd3 00:44 03 Mar 2003

OK, I've just been re-arranging the power supplies to make the drain more even, but it's a high power jobbie (I forgot to mention that I'd upgraded that) and should be able to cope with the drain easily. All the hardware seems to think it's getting enough power anyway. I did wonder if adding that last drive was overpowering it, but it seems not.

The reason for all the drives... I wanted the 120 for games, they're getting so big and I just wanted to futureproof while the hardware was cheap. The 80 was for music, I was planning on transferring my Sibelius files across, but then I decided it was waaaay to expensive. I also had some ideas about dual-booting.

Anyway, I've decided I'm ditching Windows. I've got all that memory and I'd only be able to use two thirds of it? And I don't like ME and I'm not going to have anything to do with the XP 'We're looking over your shoulder 'thingie, so Linux it is.

I've just been checking the master/slave relationships of everything and labeling all the drives, then I marked them 'A' 'B' 'C' and so on. Then I tried just reloading the Mandrake 8.1 that worked before, and just as it was about to come up I got a new message. Something about 'X' loading too fast, so it was shutting sown for 5 minutes....

Thanks for the advice. I'm going to try booting up a drive at a time tomorrow (I was really hoping to avoid all that!).

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Comment créer un compte PayPal pour payer en ligne ?