is my epson dead?

  jammin 18:07 07 Apr 2006
Locked

I have an epson c42 inkjet, red and green lights are on and nothings happening. Ive reinstalled drivers, changed cable, cleaned out ink pads, installed ssc utility etc and still no joy. I would be happy just to throw it out but I recently bought several cartridges which cost as much as the printer - any ideas or should I just count my losses?

  Totally-braindead 18:17 07 Apr 2006

You could try the self diagnostic on this page click here What does the manual say that both lights being on means?

  Fruit Bat /\0/\ 18:28 07 Apr 2006

Problems with my Epson C42UX printer, the red and green light began flashing and a window popped up, saying, take it to your services center because some parts have reached the end of their life.

Printer companies set a “protection counter” on all printers , it’s an internal counter measuring the amount of ink wasted by head cleaning.

Reset the "protection counter" as well as clean the “waste ink pad overflow”.

1. Unplug the power and USB cables from the printer. Pry open the C42UX printer, careful not to break anything. Use a flat blade screwdriver to pry it apart; there are two-three tabs at the back and two at the front. Gently push them in, and then using a bit of force pry apart the cover.

2. Next remove the two (2) waste ink pads. They are located at the back on the left hand side. I used the flat blade screwdriver to lift up the ink pads (they were soaked). Please use rubber gloves as it gets very messy.

3. Next wash them with just plain hot water until they are white again. I just let the hot water run on them (the pads are about three inches long).

4. Once washed dry them using a hair drier. (you could place it the sun for a few hours or on top of your heater or maybe in a heated oven; (make sure you do not set it on fire with too much heat).

5. Once dried place the pads back in the ink waste bin at the back of the printer.

6. Closed the printer cover and put back all the pieces and plug in the USB & power cable and turned it on. (Yes the lights are still flashing).

7. Go to this link and download this software: click here

8. Install the software and run it.

9. Select your printer and model number ( It only says C42 there is no UX, choose it anyway). It will ask if you replaced with new pads; say “YES”. Then close the window.

10. Now right click on the SSC service utility, it looks like a printer icon near your clock in the task bar.

11. Then click on reset counters. You can do all other stuff with this utility too.

12. Turn off the printer power and then turn it on again. If necessary un-plug the power cord from the back of the printer, wait 20 seconds. Plug it back in.

13. IT WORKS AGAIN.

  bluto1 18:44 07 Apr 2006

What Fruitbat/\0/\ said is total truth. If, however you cannot go this route, take it to your nearest Epson service unit where it will cost £25.00 minimum to service and reset it.
I`ve done both and thr best way is to get your fingers a little dirty.

  jammin 08:46 08 Apr 2006

i tried all of those things fruit bat, the only thing that didnt happen was I didnt get the "have you replaced pads" and couldnt find it anywhere. I reset counters etc but still dead as a doornail. havent got the manual totally braindead and for some reason I cant download the self diag

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?