Multiple problems after Windows XP repair

  Jungle 21:42 15 Dec 2009

Please can anyone help ?

After repairing Windows XP home edition using the Windows XP disc I have a number of problems with the following machine:

click here

Service Pack 2 & 3 updates have been installed ( which I thought might have resolved the issues but sadly no! )

Problem 1) No Ethernet appearing in Device Manager on standard XP log in therefore no internet connection. If I log into SAFE mode I can see it fine, if I log into SAFE mode with network its not there. ?

I found what appears to be the correct controller here but I cannot seem to get it installed ?

click here

When I unzip and click on the setup.exe file it just states that it cannot find any inf files ? What do I need to do to correct?

Problem 2 ) No USB controllers are showing in the device manager ? How do I get these back ?

Problem 3) VIA CPU to AGP2.0/AGP3.0 Controller is yellow flagged. I have tried to uninstall and reinstall but yellow flag remains.

This is the driver I have used:

click here

Thankyou for any help received I am at my witts end !


  Jungle 21:50 15 Dec 2009

Any an uncanny bit of luck I have resolved problems 1 & 2.

I went into the Motherboard set up and for some bizzare reason the USB and Ethernet settings were set to " disabled " setting these to enablled has sorted the problem out.. If only I had spotted this a day ago !

I still have issues with the AGP controller though ( item 3 ) if anyone has any ideas ?


  User-312386 22:25 15 Dec 2009

After the repair, you have to re-install the motherboard drivers, do you have onboard graphics?

  Sea Urchin 22:27 15 Dec 2009

Try downloading from the VIA site. Click 'Download the latest version for Windows XP' and save to the desktop. Then double click to run and unzip - then run the file Setup.exe to install the driver

click here

  Jungle 07:39 16 Dec 2009

Hi thx for the replys. The graphics are not on the motherboard but are supplied by an old agp slot nvdia fx5200 card. I tried to upload the appropriate nvidia drivers but they stop half way through stating no card matching. I guess this is because the agp2/3 controller is not properly installed.

I cannot find any motherboard drivers or installion dets as it appears to be quite old. Looking at the dets I found it appears to be an old
Msi board.

Thx for the idea about going to via direct I will try tonight.

Kind rgds

  Jungle 11:47 17 Dec 2009

Thankyou for the response.

Sea Urchin - I used the link you provided and updated the drivers and it all worked perfectly. Seems it does make a huge difference where you obtain the drivers from !

Thankyou to all


  Sea Urchin 12:01 17 Dec 2009

Glad that sorted it - maybe tick box and click Resolved :@)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires