MTU value.

  the hick 19:52 30 Mar 2009
Locked

On my Pluscom wired router, despite several attempts, I cannot change the MTU to 1432, which I believe is correct for TalkTalk. The router defaults to 1500, although BB is working. Does the MTU value make much difference? NAy advice much appreciated.

  MAJ 19:57 30 Mar 2009

Set it to Auto, if you have that option, that's what my Linksys is set to. I'm also with TT.

  birdface 20:01 30 Mar 2009

1400 going with this.click here

  birdface 20:16 30 Mar 2009

An old PCA thread. click here

  Grey Goo 21:34 30 Mar 2009

The best value for MTU is that value just before your packets get fragmented. How do you find that out? By using Ping at an command prompt.


Windows 2000/XP users:

Go to Start/ Programs/ Accessories/ Command Prompt and type the following:

ping -f -l 1472 click here
(That is a dash lower case "L," not a dash "1." Also note the spaces in between the sections.)

Press Enter. Then reduce 1472 by 10 until you no longer get the "packet needs to be fragmented" error message. Then increase by 1 until you are 1 less away from getting the "packet need to be fragmented" message again.

Add 28 more to this (since you specified ping packet size, not including IP/ICMP header of 28 bytes), and this is your MaxMTU.

Note:If you can ping through with the number at 1472, you are done! Stop right there. Add 28 and your MaxMTU is 1500.
~~~~~~~~~~~~~~~~~~~~~~~~~~~
If you need to change anything use Dr TCP

  Grey Goo 21:38 30 Mar 2009

Where it says click here should be
xxx.dslreports.com
xxx = www if I type it in will get another click here

  woodchip 22:26 30 Mar 2009

Try using click here

  cocteau48 07:55 31 Mar 2009

Whatever the appropriate MTU setting which you set your router at you must ensure that the corresponding MTU setting on your computer (easily changed using either DrTCP ttp://click here or TCP optimizer click here)is set to a figure either equal to or less than the router setting. This should help the computer and router to communicate without fragmenting packets.

  Stuartli 10:29 31 Mar 2009

TCPOptimiser does the same task in a few seconds.

  Stuartli 10:31 31 Mar 2009

Yes, it does make a difference, as I found out about 18 months ago even though TT had worked faultlessly up to that point...:-)

I eventually found this explanation:

click here

and changed the MTU from 1472 to 1432.

Instant success...:-)

  Grey Goo 21:00 31 Mar 2009

Well this little gem has optimised my MTU at 1500, however the router has a default of 1400 and the ping test cofirms that, so I will stick with pinging.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?