MSVCR80.dll

  Drusen 17:00 26 Dec 2007
Locked

Hello

I've been trying to install some software on my PC, but I keep getting this error message:

"Executable 'D:\setup\rsrc\cod2.exe' had the following unrecoverable error:

Couldn't find library MSVCR80.dll (required by c:\PROGRA~1\window~4\MpShHook.dll) Please ensure that it is installed".

I am totally bewildered. I've searched the internet for answers. I downloaded a program (RegCure) to see if that would do the trick, but it didn't.

Any help would be gratefully received.

Many thanks

  mfletch 17:07 26 Dec 2007

Hi, What software is it?

Try another download site,

mfletch

  FungusBoggieman 17:10 26 Dec 2007

click here

chuk this in sys32 folder

  Drusen 17:10 26 Dec 2007

The software title is 'Call of Duty 2'.

  Drusen 17:14 26 Dec 2007

Thanks for the responses so far.

Incidentally, I've searched for MSVCR80.dll and there appears to be about 3 copies of it on the HDD.

  FungusBoggieman 17:18 26 Dec 2007

you could try
start/run type in the run box

regsvr32 MSVCR80.dll

  Drusen 17:54 26 Dec 2007

I just tried what you suggested and I got this message:

'LoadLibrary("MSVCR80.dll") failed. The specified module could not be found.'

I found a copy of MSVCR80.dll in this location:

C:\WINDOWS\system32\ZoneLabs\avsys

I copied the file and pasted it into the system32 folder, but I just got another error message.

I will try downloading a copy of the file, like you suggested above. I presume that I'll be able to unzip it with Winzip.

Thanks

  Drusen 18:10 26 Dec 2007

Just downloaded the file and copied it to the system32 folder. Unfortunately, I got the same error message when I tried to install the new software and when I tried typing regsvr32 MSVCR80.dll in the run box.

  Drusen 18:13 26 Dec 2007

Incidentally, the other error message is:

'Runtime error.

Program: D:\setup\rsrc\cod2.exe

R6034

An application has made an attempt to load the C Runtime library incorrectly.

Please contact the application's support team for more information.'

It looks like this is what I will have to do.

  Drusen 18:18 26 Dec 2007

I've just pasted the original error message into Google and it appears from the forum message that I found that the problem is caused by Windows Defender - it has to be uninstalled! I will try turning it off first.

I will keep you posted.

  Drusen 20:34 26 Dec 2007

I had to uninstall Windows Defender and it worked.

Thanks for your help.

Best wishes

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?