Msgsrv32 error

  Catastrophe 08:47 29 Sep 2005

The following appears on boot:


An error has occurred in your program. To keep working anyway, click ignore and save your work in a new file. To click this program, click close. You will lose information you entered since your last save.

If I click Ignore - nothing happens.
If I click Close - I get:


This program has performed an illegal operation and will be shut down. etc.

Details gives:

MSGSRV32 caused a general protection fault in module SETUPX.DLL ... and registers.

I then get a blank desktop apart from the cursor which will move.

My only option is to power off - then the loop starts again.

I have googled and found downloads but of course I can't implement them.

Any ideas gratefully accepted.


  MAJ 09:38 29 Sep 2005

Which version of Windows are you using, Catastrophe? It looks like you might have to replace a corrupt SETUPX.DLL file.

  Hamish 10:06 29 Sep 2005

Have you tried starting in safe mode

  Catastrophe 10:16 29 Sep 2005


This pc is on Win98SE. Some news on the problem.

This is the same pc as in the thread PCI RAID controller. The mobo sockets are inoperative so I am booting from PCI IDE card. The contacts are just visible at one end protruding from the socket.

It has occasionally broken the loop, as it has just now. Although I think it is a coincidence, I tried ctrl+alt+del and it showed only Nprotect running, which I ended and exited. On boot, although Nprotect would re-start, it got into Windows normally. I tried Win and Disk Nortons, and they made a few corrections. I have just re-booted again normally and am running Scandisk as well.

Re: SETUPX.dll I will try replacing this if the problem re-starts. Hamish - ditto.

I won't mark this as solved just yet.


  bosmere 10:20 29 Sep 2005

A quote from the Annoyances forum:

"re: MSGSRV32 caused a general protection fault in module setupx.dll

Have you checked in Device Manager in Safe Mode to see whether there are more than one modem listed? If so, remove them all, and reboot and let Windows detect and reinstall the drivers for them."

Hope this helps.

  Catastrophe 10:30 29 Sep 2005


Thanks for the info but there is no modem fitted on this pc. I have one pc on ISDN and no other pc (of 6) has internet access.

  sattman 10:34 29 Sep 2005

Have you made any recent changes to your system? if so what.

Has anything else in ctl-alt-del recently showed up as not working.

  Catastrophe 10:48 29 Sep 2005


"Have you made any recent changes to your system? if so what."

I added a tape drive but pc was showing this problem previously. Tape and 2nd HDD were disconnected whilst tackling this.

"Has anything else in ctl-alt-del recently showed up as not working." No.

  bosmere 10:51 29 Sep 2005

MSGSRV32 caused segment not present fault in module SETUPX.DLL

You will see this error when you try to start your computer if the DLL (Dynamic Link Library file) Setupx.dll is damaged.

If you are unable to start your computer either in the Normal Mode or Safe Mode, you will need to extract and copy an undamaged copy of the Setup.dll file from your Windows 98 CD, by following the steps detailed below.

click here for the rest of it.

Again, I hope this helps.

  Catastrophe 10:57 29 Sep 2005


Thanks again. That (with link) is in my 'ideas to try' if/when the problem arises again. At the moment it has re-booted 3 times in a row without problem.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Black Friday Deals 2017

Black Friday Deals for Designers & Artists: Adobe, Apple, Corel Painter, Microsoft Surface, Wacom &e…

Best Black Friday Apple Deals 2017

Black Friday 2017 : date, sites participants & bonnes affaires