MS Visual C++ Runtime Library Error

  [email protected]#36 17:47 12 Sep 2010
Locked

I'm trying to re install my HP C7280 printer software which inexplicably stopped working this week.
I was getting a window to say the driver/software had not completed install (wich was false as I had been using it for several months) The printer also works fine from other programmes etc and shows up in Printers and devices.
I have tried all sorts of options inc unistalling and re installing but I always come up against a window that states:
Microsoft Visual C++ Runtime Library
X Runtime Error!
Programe: C:\users etc.... \Setup.exe
This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information

I have the most upto date download from HP, which is for Win 7 X64 and I have run a Reg Cleaner as most advice on the internet seems to suggest and still no luck.

Does anyone have any ideas?

Thanks

  [email protected]#36 11:04 14 Sep 2010

Anyone?, surely I haven't come up with a problem no one can solve!

  skeletal 12:26 14 Sep 2010

I assume your problems are with the “extra” software you get with printers i.e. that the printer’s drivers are all OK otherwise you would not be able to print from other applications.

This kind of message suggests to me that the “extra” software has a bug in it.

You also said “it inexplicably stopped working”. I wonder if, putting 2 and 2 together and getting 5, you have recently done a Windows/software upgrade? There is a chance that such an upgrade has changed a dll (or something) that the printer software was relying on which would then manifest itself as a bug.

Any chance of a system restore to before this may have happened?

I’m not an expert in this area, but your cry for help from the wilderness prompted this, probably not very helpful, reply!

Skeletal

  [email protected]#36 12:32 14 Sep 2010

Thanks for the interest but - No known updates apart from the standard MS weekly updates.
So far I have run reg cleaner, run something called SFC /scannow, and tried a system restore - however that finished saying it was unsuccessful and made no changes (twice)
And yes it's the asssociated software that I'm trying to fix.

  skeletal 12:58 14 Sep 2010

Ah, the ever reliable system restore. I reckon that it fails more times than it works for me (I very rarely try to use it, but when you really need it, it will of course fail). One thing I discovered is that it will not work if you have anti-virus software running so you could try disabling any you have and trying again (but I’ve had it fail without AV software running as well).

It is not impossible that an MS update has caused the problem.

A problem with any registry cleaner is that they only look for links (etc etc) that supposedly don’t tie up with software. It can happen that all this is correct, but the software calls up a dll that no longer has the required code (i.e. if it has been upgraded). I thought all that was in the past, but I bet there are still bugs that crop up from time to time.

But, there still may be a problem with the registry that the cleaners haven’t picked up (I have had this in the past). Try looking through it searching for any words to match your software. Be warned though, you may find mountains of stuff and may find it hard to determine what is correct, or not, and deleting stuff without knowing what you are doing could land you in even more trouble! I recently had to do some manual editing and removed several hundred incorrect entries that CCleaner did not find.

The same with SFC; it should look to check for problems in existing Windows files but may not find a dodgy additional file.

Having said all this, I would have done everything you have tried as it can often highlight an issue.

What you can now do to solve the problem is now getting beyond my limited thoughts.


Skeletal

  [email protected]#36 13:11 14 Sep 2010

Interesting, it's CCleaner that I've used. I have uniblue somewhere so might try that as well. Also interesting about AV software, I might turn that off and have another go - in fact might turn that off and see iff the install works?
Thanks. I'll let you know.

  Marko797 13:17 14 Sep 2010

have you tried System Restore in Safe Mode? Usually more reliable this way. I'm not sure however that skeletel is correct in: "One thing I discovered is that it will not work if you have anti-virus software running".. I've never had to disable this prior to any System Resore.

  skeletal 14:16 14 Sep 2010

Marko797: I am correct BUT, it seems to depend on which AV software you use. As there are many versions now in use I can’t say which ones will have an effect, and which don’t. To make life easy I assume they all have an effect.

I discovered this ages ago, and sometime later started seeing other people on the web saying the same. If memory serves, Sophos and Norton definitely stopped it working (but of course, as new versions appear they may now work, whilst others do not).

Trying it in safe mode is also a good (better?) idea.

Installing software without other stuff running is also a good idea; but once again, I've quickly installed a few things with about 20 windows/apps runing and not had a problem. Go figure!

Skeletal

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?