Mozila Firefox very slow loading - help please

  Never again 17:15 25 Oct 2008
Locked

Hi

I have windows xp on a laptop with 2gb ram and quite happily run most things.

Internet explorer is my default browser, but I use Firefox version 3.03 to moderate a yahoo group, which opens 4 tabs when opened.

My problem is that it takes over 2 minutes just to open and retrieve the pages when initially starting, which seems a very long time. I have some add ons installed but this still seems a very long time.

Internet explorer opens immediately when clicked, as do any other additional firefox windows.

Does anyone have any suggestions to make it faster, or is this normal.

Thank you

  skidzy 17:37 25 Oct 2008

click here for the maxrequests,i would say change to 8 not 20.

  Never again 17:53 25 Oct 2008

..but all 3 settings were already set to true, true and 8.

Should I change the 8 setting to 20?

Is 2 minutes too long to load from click to opening?

Thanks for your help.

  DieSse 18:05 25 Oct 2008

Try cleaning out the internet cache.

  Never again 18:09 25 Oct 2008

I run ccleaner regularly, and I thought that that would do the job.

Is there another way to do this with Firefox or do I need to do it another way?

Thanks for your suggestion.

  skidzy 18:46 25 Oct 2008

Changing to 20 may render the browser unstable,you can of course try this and if no joy,change back.

2 minutes is a long time for any web page to open.I think i would start by removing one addon at a time and reboot...i think your problem lies with an addon.


Do other web pages load ok ? if so,it could be the site server has issues.

  Never again 20:10 25 Oct 2008

I tried the setting of 20 and it now loads from first click to working in just about a minute, which still seems like a long time, but an improvement obviously - as long as it is stable.

I'm going to do as you suggest and remove a couple of add ons.

I only really use Firefox to moderate my Freecycle group, so I can't really say if it is any faster loading other pages from scratch as i always save settings when I quit so every time I open the browser it goes to the corrrect pages.

I don't think the server is the problem though as Internet explorer loads in seconds.

Thanks again.

  Never again 15:29 29 Oct 2008

Thanks for all your help.

It now loads in about a minute, which is half the speed it did before, which is not brilliant, but definately an improvement.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?