Mouse wont work on PS2 or USB

  taffyal 15:02 22 May 2009
Locked

I've been running 2 PCs through a KVM switch. I now want to seperate them, but the one I want to move seems to have no power to the mouse through the PS2. I bought a USB adaptor, but it wont work through that either!! Other things work from the USB, just not the mouse or keyboard. I assume that on the KVM, they were getting power from the other PC. Any ideas how to make it work on its own please?
BTW, the mouse & keyboard are working OK, tested on another PC.

  Ex plorer 19:40 22 May 2009

Not sure how old your PCs are or what OS you are running but you may need to plug in the mouse and keyboard before booting the PC up then the system will find the mouse and keyboard.

  woodchip 19:59 22 May 2009

you need to use keyboard to navigate to device manager with mouse attached uninstall all mice the restart computer with mouse in

  jack 20:03 22 May 2009

to you

USB is 'Hot plugable'
PS2 is not.
The devices- mouse and keyboard have to be in place before boot up, adaptors no withstanding.

  woodchip 20:27 22 May 2009

jack I don't think he damaged is mobo as other usb still work. but he could have blown ps2 if he plugged them in live

  taffyal 15:54 23 May 2009

Thanks for advise, but everything was plugged in when I booted up. USB/PS2 adaptor works well on other PC.When I reconnect the faulty one with PS2 to same mouse & keyboard mouse & keyboard through KVM switch, all works fine again.When I try to run it independently, no mouse!!

  woodchip 18:35 23 May 2009

I would say KVM as changed drivers for your mouse, and its set its own to default

  woodchip 18:37 23 May 2009

PS thats why I said to uninstall Mouse in Device Manager then run Add New Hardware wizard in Control Panel. If its USB wireless do not forget you have buttons to press on the dongle and the Mouse for it to work

  taffyal 13:03 24 May 2009

Tried this to no avail.Doesn't find mouse, whether on usb adaptor or PS2.Its not wireless, no dongle.It's an old Time pc, about 4 yrs old, with MSI P4MAM-L (MS-6787) mobo.
I turned it off to connect/disconnect PS2.
Thanks for advice. Al

  woodchip 13:22 24 May 2009

If you have a OS disc why not run Repair. You will need to do all the MS updates after running it

  woodchip 13:23 24 May 2009

If you have a OS disc why not run Repair. You will need to do all the MS updates after running it

PS only other thing it can be if that does not work is it may be a faulty mobo. but I think the KVM as mucked it up

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017