Mouse not working as it should

  Teasle 15:47 25 Sep 2005

Hi there - can somebody please help.
Yesterday my pc froze (probably because I had opened too many programs at once). Since restarting my pc, I have found the mouse doesn't work properly. It doesn't respond to the movement most of the time and if I run the curser over the tool bar or desk top icon, for eg, it doesn't open it, but brings up a menu, as if I had right clicked.
Sometimes the curser disappears all together for a few seconds. When it is there, and I click on the right hand x to close a program, nothing happens.
So I ran Registry Mechanic, CCleaner, Clean up, A-squared, AVG, Adaware, spybot, Spyware Blaster. I also restored by going in to DOS and doing SCANREG /RESTORE. Still no change. Any ideas what I can do to correct this?
I run W98.
Thanking you all in anticipation.

  spuds 16:11 25 Sep 2005

What type of mouse are you using, and how long have you used it. Have you tried re-installing new drivers!.

  Stuartli 16:20 25 Sep 2005

Try uninstalling the mouse in Device Manager and then rebooting.

Is it a wireless mouse? Perhaps the frequency has been altered or, alternatively, the batteries are starting to go flat.

  Teasle 16:37 25 Sep 2005


It's a cheap Trust mouse that came with my pc 3 years ago. I will look at re-installing, devices etc.

  jack 17:22 25 Sep 2005

Go to Pets at hHme - they have lots of mouses in all sorts of colours.
Seriously though - a new mouse and have a spare
They come cheap as chips as that man says

  woodchip 18:32 25 Sep 2005

put the win98 cd in, and let it run setup. this will leave your files intact

  Teasle 19:33 25 Sep 2005

Hi Spuds and Stuarti - I tried the re-installing and updating the driver but still have the same problems.

Hi Jack - think I'll go to Staples next door to Pets At Home :) and get one that doesn't need feeding.

Woodchip - thanks too. Maybe I will try this too if I'm feeling brave.

  Stuartli 19:44 25 Sep 2005

Have you tried cleaning the rollers and the ball in the mouse?

You get a buildup of dirt on them and a cotton bud (slightly moistened) helps to remove it.

But perhaps I'm telling my grandmother how to suck eggs?

  Teasle 21:16 26 Sep 2005

Thank you to all that responded.

My Dad popped round with a spare mouse this morning and it worked fine so the problem must have been with the hardware as suggested so cheers all.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

See the Best Button Badge Designs of 2017

iPhone X review

Black Friday 2017 : date, sites participants & bonnes affaires