Mouse left click sticking on slide bars etc.

  m800afc 22:58 15 Jan 2010
Locked

Windows XP Pro SP2; ASRock 775VM800;
Pentium 4; 3GHz; 2Gb RAM

My mouse is sticking, amongst other places on the scroll bars and title bars of most of my applications. I used to just click on the scroll bar, and release it when I wanted to. I now have to click on, slide and click off. Same with the title bar. The mouse is "sticky". In addition to this, when I am using any text editor to highlight text, for example when cutting and pasting, I have to click at the start, drag to the end and then click at the end before I can ctrl-c.
How can I unstick it. It happens no matter which mouse I use, so I know it is not a physical mouse problem.
Everything I have found on t'interweb just tells me to clean my mouse, which is definitely not the solution.

  rdave13 23:08 15 Jan 2010

Go to folder options and make sure ' Double-click to open an item (single click to select) radio button is dotted.

  m800afc 23:46 15 Jan 2010

rdave13
Thanks for the reply. I tried this but it made no difference.

  User-312386 00:05 16 Jan 2010

Is the mouse plugged into usb or the ps2 port?

  m800afc 01:01 16 Jan 2010

Mu mouse is a Logitech cordless Clik. My other mouse is a Logitech VX Revolution. Bothe exhibit the same problems. I assume therefore that it is a software problem.
HTH

  m800afc 01:01 16 Jan 2010

Both are usb

  User-312386 01:06 16 Jan 2010

Try using them on the PS2 port - I am always of the opinion thats what the PS2 port was for, a mouse, never trusted USB and a mouse to be honest as it has to be driver controlled whereas the PS2 does not

  mooly 08:28 16 Jan 2010

Have you turned on "Clicklock" in mouse properties in control panel by mistake.
I actually prefer that setting... although I am referring to Vista I guess XP is the same.

Found this
click here

  Andsome 08:30 16 Jan 2010

Does it need a new battery?

  m800afc 09:00 16 Jan 2010

I have managed to find the answer. Within the clicklock dialog box is an advanced setting. This alters the clicklock timing, setting to the maximum restores the problem.
It seems the clicklock had been selected by the Logitech mouse driver update.
Thanks all

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Intel Coffee Lake release date and specifications

12 Amazing British Craft Beer Label Designs

watchOS 4 review

Les meilleurs navigateurs internet 2017