Mouse detected but not functioning

  georgiebhoy 19:59 14 Feb 2015
Locked

Hi,

I have resurrected my old viao laptop mainly just for some nostalgia and specifically to play Max Payne 2 which refuses to place on my windows 7 desktop. A clean install of XP +sp2 has led to an annoying problem which I has exhausted my limited knowledge. All mice are being detected but not functioning. This includes a simple dell wired three button and a logitech wireless versions which makes me think it is not a driver issue (although these are up to date) but I am no techie. All the mice are working on other computers. The mice show up under HID in device manager and the laptop pad shows up under mice and other pointing devices and is working fine. I don't know if these locations are normal. Any advice would be greatly appreciated. Thanks

  rdave13 20:59 14 Feb 2015

Try booting without the mouse connected. Once logged in and on the desktop connect the usb mouse. See if it detects it and installs the generic drivers again.

  georgiebhoy 10:01 15 Feb 2015

Plugging in a mouse after reboot results in the windows recognition sound being played but nothing else. When I try the wireless mouse the usb dongle was lighting up every time I moved or clicked the mouse. I tried disabling the touch pad to see if there was a conflict. Device manager says everything is working.

  georgiebhoy 10:02 15 Feb 2015

Plugging in a mouse after reboot results in the windows recognition sound being played but nothing else. When I try the wireless mouse the usb dongle was lighting up every time I moved or clicked the mouse. I tried disabling the touch pad to see if there was a conflict. Device manager says everything is working.

  georgiebhoy 12:40 15 Feb 2015

I run AVG diagnostics and it came up with a whole load of errors which suprised me as this was a clean install on a reformatted disk. I had installed for the virus protection but am going to unistall as the memory usage is consistently 100k-200k+. I also reinstalled the sony original driver for the touch pad (again) and have a partial solution. It now responds to a microsoft wireless mouse but not the simple Dell wired. If the wireless works I might just leave it alone now but will try your solution later. Thanks for the advice.

  mole1944 13:10 15 Feb 2015

Go get yourself a cheap replacement mouse £2-3 se if that cures the problem,the other thing if it's optical make sure the light window id clear and the surface your using it on is not plain. If it's a ball mouse make sure the ball is grease fee and take it to pieces to ensure it's not full fluff and crud.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone