Moto G connects to WiFi as 11b (not 11g)

  Batch 18:24 17 Apr 2014
Locked

My router (3com 3CRWDR101A-75) supports 802.11b/g (but not 11n) and my Nexus 7, 2 laptops and netbook all connect as 11g. But Moto G only ever connects as 11b (even when right next to the router) . I assumed it would connect as 11g (the specs say it supports 802.11b/g/n)

I've tried resetting / rebooting the router - all to no avail.

Any ideas?

  Secret-Squirrel 19:42 17 Apr 2014

"Any ideas?"

If your router supports it, try setting its wireless to G-only mode.

  Batch 13:02 18 Apr 2014

Well I'm completely bamboozled.

I switched to 11g only on the router. Cleared all references to the old connection, rebooted router (with phone off). On reboot made sure that there was no record of the phone in the router. Switched phone on. Connection made and.... wait for it...... router shows connection as 11b. How can that be???

And to make it more interesting, looking at the WiFi connection on the phone, it shows Link Speed as 54Mbps (although it drops off as I move around my manor). So it can't be 11b (surely) if it is 54Mbps. Maybe it's the router reporting it incorrectly (but why just the phone showing as 11b and not all the other things that are connected over WiFi?).

Time for a pint I think.

  Secret-Squirrel 09:18 19 Apr 2014

"on the phone, it shows Link Speed as 54Mbps"

With that speed it must be connecting using wireless G.

"......Maybe it's the router reporting it incorrectly..."

That sounds like the most likely explanation but it is weird that it's only reporting the one device incorrectly.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

What is ransomware and how do I protect my PC from Petya?

Microsoft Surface Studio – the artist's hands-on review

Original iPhone review

Comment mettre à jour Kodi ?