Motherboard Upgrade

  Retiredidiot 12:29 23 Mar 2007
Locked

I took a brave step (for me!)to upgrade my six year old Fujitsu PC to the latest technology. I installed a MSI K9N Neo motherboard an AMD 64x2 Dua-Core Processor and 2Gb DDR2 memory (Two 1 Gb cards) First mistake I made was that the motherboard only has two slots for the drives and I have two hard drives a DVD and a CD writer, the last two are physically two drives. I overcame this by buying a ATA/133 controller that supports two drives. Everything works except that the PC will not recognise the CD writer. I have tried connecting the drive in another slot but no joy.

Also: The motherboard has a two green and two orange slots for the memory and it is not clear which two I should use, I have put one card in each(One Green & One Orange) and it all seems to work ok, mind you it also works if I do it the other way (using the same colours)! The BIOS shows 2Gb whichever way you connect them.

  skidzy 14:40 23 Mar 2007

"PC will not recognise the CD writer"

What does Device Manager say,any yellow exclaimation marks ?

Missing cd/dvd drives can be normally associated with the removal of burning software such as Nero/Roxio/Sonic/Easy CD Creator etc.
And not showing the drive in My Computer.


Try the below link ,if still no luck follow the Procedure of removing the upper and lower filters.


click here


If no joy with the above fix,try the Microsoft Guided Help

click here scroll down to the Guided help download and follow the instructions.

If still no joy,follow the manual fix below.

If you have further any error codes,please post them.


Restore Missing CD/Dvd Drives

Missing cd/dvd drive
If it is showing an error code:
Code 19, Code 31, Code 32, Code 39, or Code 41
, delete the drive.

Then follow these directions for clearing the Upper/Lower Filters: (might want to print this out)

1. Click on Start --> Run --> and type in 'regedit' followed by the enter key ( if Vista Start search or windows+R )
2. Expand the "HKEY_LOCAL_MACHINE" key (looks like a folder) by double clicking it (or
3. clicking the "+" next to it.)
4. Expand the "SYSTEM" Key
5. Expand the "CurrentControlSet" Key
6. Expand the "Control" Key
7. Expand the "Class" Key
8. Please look for a key containing the following string of letter and numbers:
{4D36E965-E325-11CE-BFC1-08002BE10318}
9. High light this key by left clicking once on it
10. On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these please delete them by right clicking on them and choosing "delete"
11. Please exit the registry by clicking on the "X" in the top right hand corner of the screen

Reboot your computer

.If in any doubt editing the registry,please create a System Restore point first and also backup your registry....The guidedhelp from Microsoft on backing up the registry is a good lesson for anyone to learn. click here


Creating a System Restore point:

Start/All Programs/Accessories/System Tools/System Restore…follow the prompts.

If this does not work for you,i would say its not connected correctly or faulty cable/s

  Retiredidiot 15:19 23 Mar 2007

There is a yellow question mark against Other Devices and when opening it out there is another one against Unkown device. I have tried loading drivers with Wizard but it can't find any.
I hadn't loaded Nero, so I did and no joy. I also tried the fix "missing cd drives" that you advised
and again no joy.

  skidzy 15:27 23 Mar 2007

Have you run the motherboard's driver and utilities disc ? if not run this.

  skidzy 15:28 23 Mar 2007

From my above post,have you tried to locate the upper and lower filters manually,sometimes only one will be present...delete this.

  Retiredidiot 16:53 23 Mar 2007

Just tried the filter deletion, there wasn't an Upper Filter but there was a Lower Filter which I deleted, did a re-boot but still no joy. I did create a restore point, before doing this, should I restore back?
Do you think it may be that my drive is not compatible with the new Motherboard?

I did run the motherboard drivers and utilities disc.

  Retiredidiot 17:17 23 Mar 2007

The yellow question marks, in device manager, I can turn off by disabling the nVidia Raid Function in the BIOS. I have no idea what this is & whether it should be on or off.

  Retiredidiot 20:07 23 Mar 2007

My terminology might not be quite right, when I say that the PC does not recognise the cd writer what I mean is thatthe disc drive doesn't even appear under "My Computer"

  Totally-braindead 20:31 23 Mar 2007

RAID is when you use 2 identical hard drives. I won't go into it as you're not using it so just disable it in the BIOS, it will do no harm.
Regarding the memory slots - did you not get a manual, RAID is explained there as well as the memory. I would imagine the motherboard supports dual channel memory if you use the correct slots, hence the different colours. If you want to use dual channel memory you install 2 identical slabs of memory into the same coloured slots, if you don't you install them into the first and second slot.
Unfortunatly I have to go out now but the board should have 2 IDE slots for the ribbon cables and you can install 2 IDE devices onto each slot allowing you a total of 4 IDE devices, these can be IDE hard drives or IDE optical drives.
The ribbon cable has 3 connectors. One goes to the motherboard and the others go to the hard drives or optical drives. The one furthest away from the motherboard is for the master and the one in the middle is the slave. Check what you have the CD writer set at and which connector you are linked to.
I'll check back later when I have a chance to download the manual.

  Retiredidiot 09:15 24 Mar 2007

When you say you can connect four drives to this motherboard do you mean SATA drives? Mine are not SATA.

  Totally-braindead 15:00 24 Mar 2007

When I say you can install up to 4 drives I stated IDE drives not SATA. But I was wrong.
click here this is the board and I haven't seen one like this before as it can only take 2 IDE devices, mine can take 4 yours is obviously different.
Have you checked the jumpers for the cd writer and how is the writer connected, did you connect it to the IDE slot on the motherboard or is it connected to your ATA controller?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?