Motherboard problem with GPU install

  Splat-The-Cat 17:33 09 Mar 2013

Hi everyone, I am new here and have a serious problem with my PC. I was advised I needed to change my PSU and Graphics-card to play Guild Wars 2 and was advised I could use the following with the motherboard I have: PSU: 550W OCZ Technology ZS Series OCZ-ZS550W Graphics card: 2GB EVGA GTX 650, 28nm, PCIe 3.0 (x16), 5000MHz GDDR5, GPU 1058MHz, Cores 384 I installed the PSU and it worked fine. I then installed the Graphics-card but as soon as I switched the PC on nothing happened.

The problem I have now is NO power comes on at all:

• No lights turn on • No noise is heard • No fans turn at all • Monitor says "No Signal Connected”

I think the motherboard has died and I don’t know if the Graphics Card either as the pc never turned on.

The PSU ‘IS’ still working as I have done the “paperclip” test so I believe I may need a new motherboard and that the motherboard may have not been able to support the Graphics card in the first plae.

System is as follows: Packard Bell MCP73PVT-PM (ixtreme M3720) Chipset – NVIDIA GeForce 7100 Southbridge – NVIDIA nForce 630i

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600) System Manufacturer: Packard Bell System Model: ixtreme M3720 (Motherboard) Processor: Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50GHz (4 CPUs), ~2.5GHz Memory: 4096MB RAM Available OS Memory: 3840MB RAM DirectX Version: DirectX 11 Card name: NVIDIA GeForce 7100 / NVIDIA nForce 630i DAC type: Integrated RAMDAC PSU - Delta Electronics DPS-250AB-22 D 250W

Any help would be greatly appreciated Iain

  Chronos the 2nd 17:55 09 Mar 2013

Did you try it with old graphics card reinserted?

You did connect all cables to the GPU and motherboard from the PSU?

Check that you have not dislodged any other components particularly a RAM module as that will obviously cause problems.

Sent from my iPhone.

  Splat-The-Cat 18:02 09 Mar 2013

When I originally installed PSU, the Graphics were fine as they are on-board.

I switched off, installed new Card and checked everything was connected, then went to switch on and nothing happened and now there is NO power at all, no matter what I have tried.

  Devil Fish 20:54 09 Mar 2013

if memory serves correct some Packard Bell machines use proprietary psu's ie non standars atx designed for their machines only (was this checked ) if you have tried to shoehorn a standard atx power supply in this may well be the cause of your problem

i would suggest put old psu back and see if you can get machine back to working state on the onboard graphics

if it is case of wrong psu then chances are you have blown it (the psu ) but hopefully not the mobo

  Splat-The-Cat 21:36 09 Mar 2013

I'm not sure it's the PSU as I first installed the new one and used the PC for 2 days with the on-board graphics BEFORE I then started to install the new Graphics card. It was when I pressed the power button to turn on after the new Card was input that nothing worked.

This makes me believe it's something else possibly


  BRYNIT 23:24 09 Mar 2013

Remove new graphics card and use on board graphics.

Remove new power supply and try old power supply.

If it works the new power supply could be faulty.

  Splat-The-Cat 19:57 10 Mar 2013

Tried everything. Input old PSU again and removed new Grahpics-card and still no power. I think the motherboard must be fried as NOTHING I have tried works.

(as a side note - I don't know if new GPU is okay as I never got a chance to use it andf now have no access to my Hard Drive).

I assume I may need to buy a new (mini)ATX?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?