More Wireless Connectivity Problems

  Gooddog 12:59 03 Apr 2006

Hi Guys

I'm new here so if I'm repeating a previous problem I apologise but the search didn't reveal anything that might be relevant to me.
I have a Speedtouch 576 Wireless Router as supplied by AOL and it's configured so that the 'main' PC is connected via the ethernet cable to the router. That works fine and I can access the web directly, I don't need to invoke the AOL software.
However, I can't get my laptop to connect to the wireless network even though it says it has a connection and the signal strength is 'excellent'. What happens is, when the laptop boots up it finds the wireless network (it indictaes the SSID I set up in the AOL set up programme that came with the router) but it won't access the web nor even think about file sharing. I have read through a lot of the threads here and some of them offer good information but none seem to be complete in their solutions. Can anyone help please as I'm about the end of my tether, a state most seem to be in at this point!

Thanks to all in anticipation


  wobblymike 13:10 03 Apr 2006

see if the info here helps post back if not

click here

  mgmcc 14:25 03 Apr 2006

<<< However, I can't get my laptop to connect to the wireless network even though it says it has a connection and the signal strength is 'excellent'. What happens is, when the laptop boots up it finds the wireless network (it indictaes the SSID I set up in the AOL set up programme that came with the router) but it won't access the web >>>

Have you actually "Connected" to the wireless network? There is a subtle difference between the wireless adapter seeing and communicating with the router and "Connecting" to the wireless network.

In other words, have you run the wireless adapter's software, scanned for "Available Wireless Networks", found and highlighted the one that matches your router's SSID (network name) and selected the option to "Connect" to it? Once "Connected", the wireless adapter should get its IP address by DHCP from the router and you should have internet access.

  Gooddog 15:31 03 Apr 2006

Hi mgmcc

This is where I'm on shaky ground....I think it's connected, the indicator in the system tray gives me the wireless n/work name and says signal strength excellent, well to begin with anyhow. After a short while it seems to discconect and then connect again almost constantly going between unavailable to excellent signal but even when stable and connected I can't access the internet via the laptop, what I can't remember is whether the laptop just found the network or if it scanned and asked me to select, I certainly didn't run the apadter's software to do this so from what you say I suspect this could be one of the problems at least....I am going to be late home tonight so I won't be able to try this out until tomorrow night but I'll let you know what happens then.

Thanks for your help meantime.

  Gooddog 20:01 04 Apr 2006

Hi mgmcc

Well, I'm making a little progress at least. As you suspected I wasn't connected to the network but sadly, I'm still not. My laptop has an Intel 2100 wireless adapter and I tried to connect using that but it wouldn't work. Here's the steps I took.

Firstly, I treid using the new network SSID and WEP I set up using the AOL 'easy' set up disc but it failed, i then disabled both the router and the software firewalls and tried again, it failed....I then reset to default settings, obtaining the SSID and WEP from the router and tried again with both firewalls disabled and iy failed again. The stage it failed at was in obtaining the IP config both times, it was unable to renew the IP address and when I ran an ipconfig /all from the DOS prompt I got an error there as well. When I looked at the IP Config for th ewireless adapter the address is given as rather than etc so there is obviously a pattern here , do you have any ideas what I can do next please.

Thanks again in anticipation

  Gooddog 11:50 05 Apr 2006

Hi mgmcc

Just reading through some other threads and the advice you gave there and I quote below...

<Windows is allocating a "169.254" APIPA address (Automatic Private IP Addressing) because your wireless adapter is unable to access the DHCP server (your router) to get its correct address.

Although you may have everything plugged in and are getting a nice strong signal, that doesn't necessarily mean that you have "connected" to the wireless network.>

This is what seems to be happening with me, the laptop won't/can't connect to get the correct address, it fails on the IP config part and if I run IPConfig in DOS I get an error.

I also can't ping the router from the laptop.
I'm running out of ideas, can you suggest something please.

  mgmcc 12:16 05 Apr 2006

It may be that the TCP/IP protocol has been damaged in which case open a Command Prompt window and, at the prompt, type:

netsh interface ip reset resetlog.txt

and press Enter (note the spaces in the command line). The original prompt will reappear, exit the Command Prompt window and reboot the PC. Even if this isn't part of the problem, running it won't do any harm.

  Gooddog 07:28 07 Apr 2006

Hi mgmcc

I'm sorry that this is turning into a saga but, I was playing around with the wireless settings on the laptop in work and it detected a wireless network in the building, I was surprised, i didn't think we had one, the signal strength was quite low, only around 40% but I tried it anyway and it connected straight away!!! I thought it mast be a fluke but I tried again several times during the day and, connect no problem.
However, last night at home, even though it says that my network is at 100%, it wouldn't even associate with it!! The only difference I could see was that the network in work was unprotected, i.e. I didin't need a wep to connect, whereas, at home, if I don't set the network up with a wep it doesn't even set up, i.e. I have a red instead of orange WLAN led and the laptop doesn't see it at all. There also might not be a firewall enabled in the router at work, I have no way of telling however, I've tried at home with and without firewalls and it makes no difference.
It's getting really frustrating now as I know it can work, any ideas?
Incidentally, I tried the command described above but it didn't help, sorry.

  mgmcc 08:24 07 Apr 2006

At home when you try to "Connect", are you also entering the WEP encryption key that matches the one set up in the router?

  Gooddog 09:36 07 Apr 2006

Yes, it's a 128bit encryption so it a 13 character alpha-numeric as proscribed.....I've just tested the connection again just now, I'm at work and it has connected with no problem so the laptop is able to get it's IP config from this router but not from my, encrypted one, at home, as I said earlier, last night it wouldn't even associate with my network......

Thank you for your patience, I have no ideas why this might be happening, I even asked our desktop support guys, who look after the laptop, but they aren't really wireless networking peeps, so they tell me, again any help you can provide is greatly appreciatewd.
BTW, I was able to get onto th einternet via this work connection so it is working properly, I couldn't test for file sharing obviously, I don't know where this access point is but I would worry about that when I got the connection sorted.

  Gooddog 18:59 07 Apr 2006

Hi mgmcc

Nearly there!! I have track down the root of the problem although I don't know how to solve it's the wep key without a doubt. I decided to reset the router to factory settings and start from scratch and, following speedtouch's rather than aol's instructions get a connection from my laptop with no trouble. I was able to file share with no problems and when I set up aol again, I could use the internet also with no trouble. I then set up th ewireless network usim=ng the network name I assigned to it and it still worked fine.
Then, comes the problem, when I try to encrypt it, it can't get the IP config so this is obviously where it's going wrong.
Any ideas?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?