Monitor turns red, then loses signal. (Windows 7)

  DarkEagle1026.Smith 23:42 07 Jun 2014
Locked

Alright, this problem popped up a few hours ago and I've given up trying to solve it myself.

Randomly, during use, the screen turned green for about a minute, then turned red. It wasn't completely red, but more of a black and red, with all colors except for black turning red (like I had a black-and-white filter over the screen.). I opened the monitors built-in menu and it displayed color normally, so I knew that the problem wasn't with the monitor itself.

So I restarted the computer and got nothing, it was still red-and-black, even the boot screens. I restarted it again in safe mode; it got to the login screen, then signal died. I tried moving the cable from the graphics card's port to the tower's built-in port, but still got no signal. I unplugged everything and plugged it back in, no signal.

Now I'm stumped and writing this from a completely different computer. Can anyone help?

  alanrwood 09:55 08 Jun 2014

Have you tried a different cable. If you are using DVI why not try using D-Sub to check it out or whatever fits the bill in your particular installation. Other than that it is most probably the monitor. Test signals are self generated in the monitor so can not always be used to decide if it is faulty in real life. Can you borrow a monitor from a friend and try it out as a means of eliminating it from the problem.

  rdave13 10:43 08 Jun 2014

As well as trying another monitor you could also remove the dedicated graphics card physically and then try the 'onboard' graphics chip. The onboard chip is usually disabled automatically when a dedicated card is detected.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?