Modem part of Router DG834GT not working

  John Ross 09:12 05 Jul 2009
Locked

I have had a DG834GT router modem for years. Have just been given a secondhand one that appears the same. I was trying to set up the second one, first by updating firmware to v1.2.19, then entering the same configuration as the old router (first manually, then using the backup config file from the previous router.
The wireless and LAN seem to work OK, but I can't get an ADSL connection. I am with BTbroadband (with dynamic IP address I believe) that has been pretty relaible, and it works when I go back to the old modem/router.
In the new router no IP address is allocated, and when using the wizard, it can't find an ADSL connection.
I wondered if the different MAC addresses of the 2 routers may be causing a problem, but this firmware update does not seem to allow MAC spoofing : please correct if this is wrong. If MAC spoofing were to be the solution, would I get this with 3rd party firmware?
Or is the "new" router bust?
Any thoughts and ideas gratefully received!

  Boghound 12:00 06 Jul 2009

Just start from scratch by using an install disc for the "new" modem...but if the old one is working why bother with the "new" one!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?