missing ntfs file

  Newuser3605 21:52 22 Aug 2009
Locked

Hello,
My computer won't start due to missing or corrupt file
system32\drivers\ntfs.exe
I cannot find this file on the XP PRO sp3 disk or on an old XP PRO disk. I was planning on just copying it into the right place.
By the way I have tried Safe Mode and Last Time It Started ok but nothing works. I also tried repair using chkdsk /r from C:
I tried running scanreg.exe /fix from C: but it says it's a bad command.

Has anyone any ideas? Thanks.

  MAT ALAN 21:57 22 Aug 2009

click here

might help...

  birdface 22:23 22 Aug 2009

Or here.
click here

I hope it is not the same click here as I could not open yours.

  birdface 22:33 22 Aug 2009

Maybe try the free version of Malwarebytes.

click here

  birdface 12:44 23 Aug 2009

Ignore last obviously you cannot run Malwarebytes if the computer will not start. Sorry.

  ened 14:23 23 Aug 2009

You havce tried safe mode but on the F8 button there is also the option to 'Boot to last known good configuration'.

Have you tried that?

  DieSse 14:52 23 Aug 2009

I don't have a file ntfs.exe in XP. There is an ntfs.sys - is that what you mean?

ntfs.exe looks like malware of some kind - see here

click here

Firstly - you say your system won't start - exactly what do you mean - totally can't get running at all?

One way to rid yourself of the infection is to see if you've got a friend who has a good anti-virus system, and put your hard drive intheir drive, as a slave - then run their AV and other anti-malware software on your drive to remove the infection.

  DieSse 14:54 23 Aug 2009

put your hard drive intheir drive

put your hard drive in their system - it should read - sorry.

  Newuser3605 19:50 23 Aug 2009

Many thanks for all the help.
I eventually managed to replace the missing file.
Now the problem is that when I click on an icon they all disappear leaving only the wallpaper. Then all come back without anything happening.
I have connected the hard disk as a slave and run Malwarebytes. Nothing found.
When trying to start in Safe Mode, I get a box giving me a choice of Safe Mode or System Restore. When either is selected nothing happens.
So, I now have a computer that starts and looks ok but does nothing when an icon is selected.
I have never come across anything this odd.
Any more suggestions? Cheers.

  DieSse 19:58 23 Aug 2009

I think you'll have to repair your installation, by doing a Windows repair re-install.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?