Missing Msvcr71 dll

  natdoor 17:52 23 Jun 2008

After updating AVG 7.5 and a little surfing, I rebooted to get three missing Msvcr71.dll messages. As a result, AVG would not open.

The dll was present in the System folder but Sfc stated that the file was corrupted and I could not locate a copy on the Windows 98SE disc. I tried downloading a copy and installing it in System, having renamed the original. Both versions denied access for copying or opening. I tried to register the new file but only got "bad command".

I tried to reload AVG and also Avast, which I had downloaded. Both installations failed because of the corrupted dll. I then restored my C drive using an Acronis image and Msvcr71 was restored and AVG loaded. I then updated AVG successfully. I also ran CCleaner, Spybot and Superantispyware, with only trivial problems identified.

On the next reboot, the missing dll messages were there again and no AVG. I have used Acronis again and have yet to reboot. I am not going to update AVG in case that is the cause of the corruption. However, I expect to get the problem again on reboot and wonder if anyone can suggest a likely cause and, hopefully, an enduring solution.

  exdragon 07:36 24 Jun 2008

Can I bump this one? I'm interested to find out the answer - I get this message about Msvcr71.dll when my Photoshop 'encounters an error' and shuts down.

  natdoor 09:04 24 Jun 2008

Well, I rebooted and there were no missing dll messages and AVG loaded. It is now out of date, of course.

Having looked at several sites with suggestions on resolving the problem, one was to use RegCure and another was to check the security setting for Msvcr71.dll.

Does anyone have experience of RegCure? Would it be able to influence a dll to which access is denied at OS level? And I could not find a way of accessing the file security setting. Does anyone know how to do this (98SE)?

I suggest, exdragon, that you google for solutions. Your problem may be solved by approaches which did not work for me. Good luck.

  exdragon 09:49 24 Jun 2008

I did google - there seems to be so much conflicting advice that I was really hoping someone from here would have an idea. The thought of anything to do with the registry brings me out in a cold sweat.

  natdoor 10:10 24 Jun 2008

"The thought of anything to do with the registry brings me out in a cold sweat". Doesn't it for everyone!

I assume that you have the dll in your System or System32 folder. Have you run a system file check?
I got the response that the file was corrupted. Access to the file was also denied. I don't know if this made the problem more intractable. Your problem may not be quite the same.

I guess I was lucky to have recently acquired Acronis and a caddy and to have made a mirror image, for the first time, only a few days ago.

  exdragon 16:09 24 Jun 2008

I've had a look at another thread which mentioned sfc scannow and it appeared to involve doing something in the registry - or is this only if there's a problem?

If I run it and then chicken out, can I abort it without any major headaches (apart from my own)?

  exdragon 16:10 24 Jun 2008

I see there's a link at the bottom of this page to -
Download a Free Scan & Repair msvcr71.dll Instantly!

Do you reckon I should go for that?

  exdragon 17:20 24 Jun 2008

Sorry - I've taken over your thread - are you ok with this or would you like me to start a new one?

I tried sfc /scannow, but it asked for my XP Professional service pack 2 CD and my CD is for XP Home and includes service pack 1a so it won't work.

Is there an alternative?

  natdoor 12:51 25 Jun 2008

Sorry not to have replied earlier but I lost my OS due to an error during an Acronis update. I have spent hours struggling with the consequences and am at least part way there. This was due to another loss of msvcr.dll following an AVG update.

I am more than happy for you to try ang get assistance via this post. I looked at quite a few items on google on the topic and none of them helped me. One was RegCure, which claims to fix registry and dll problems but decided not to purchase without some recommendation to is efficacy from a site member.

I wish I could help you.

  natdoor 13:02 30 Jun 2008

Having got my system restored to the way I wanted it, I tried one more time to update AVG, not having done anything else since booting. Again, I got the missing dll messages.

Following another restoration with Acronis, I downloaded the latest version of AVG from FileHippo and was then able to update that successfully. So it seems that the problem was caused by the update to the previous version of AVG that I had. I am surprised that, if this were the case, no-one else has had similar trouble.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?